summaryrefslogtreecommitdiffstats
path: root/toolchain-layer/recipes-devtools/gcc/gcc-4.6/zecke-xgcc-cpp.patch
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain-layer/recipes-devtools/gcc/gcc-4.6/zecke-xgcc-cpp.patch')
-rw-r--r--toolchain-layer/recipes-devtools/gcc/gcc-4.6/zecke-xgcc-cpp.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-4.6/zecke-xgcc-cpp.patch b/toolchain-layer/recipes-devtools/gcc/gcc-4.6/zecke-xgcc-cpp.patch
new file mode 100644
index 000000000..6192c4820
--- /dev/null
+++ b/toolchain-layer/recipes-devtools/gcc/gcc-4.6/zecke-xgcc-cpp.patch
@@ -0,0 +1,30 @@
1Upstream-Status: Inappropriate [embedded specific]
2
3upstream: n/a
4comment: Use the preprocessor we have just compiled instead the one of
5the system. There might be incompabilities between us and them.
6
7Index: gcc-4.6.0/Makefile.in
8===================================================================
9--- gcc-4.6.0.orig/Makefile.in
10+++ gcc-4.6.0/Makefile.in
11@@ -270,6 +270,7 @@ BASE_TARGET_EXPORTS = \
12 AR="$(AR_FOR_TARGET)"; export AR; \
13 AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
14 CC="$(CC_FOR_TARGET) $(XGCC_FLAGS_FOR_TARGET) $$TFLAGS"; export CC; \
15+ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
16 CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
17 CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
18 CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
19Index: gcc-4.6.0/Makefile.tpl
20===================================================================
21--- gcc-4.6.0.orig/Makefile.tpl
22+++ gcc-4.6.0/Makefile.tpl
23@@ -273,6 +273,7 @@ BASE_TARGET_EXPORTS = \
24 AR="$(AR_FOR_TARGET)"; export AR; \
25 AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
26 CC="$(CC_FOR_TARGET) $(XGCC_FLAGS_FOR_TARGET) $$TFLAGS"; export CC; \
27+ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
28 CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
29 CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
30 CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \