summaryrefslogtreecommitdiffstats
path: root/toolchain-layer/recipes-devtools/gcc/gcc-4.6/gcc-flags-for-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain-layer/recipes-devtools/gcc/gcc-4.6/gcc-flags-for-build.patch')
-rw-r--r--toolchain-layer/recipes-devtools/gcc/gcc-4.6/gcc-flags-for-build.patch189
1 files changed, 189 insertions, 0 deletions
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-4.6/gcc-flags-for-build.patch b/toolchain-layer/recipes-devtools/gcc/gcc-4.6/gcc-flags-for-build.patch
new file mode 100644
index 000000000..5eaeb0508
--- /dev/null
+++ b/toolchain-layer/recipes-devtools/gcc/gcc-4.6/gcc-flags-for-build.patch
@@ -0,0 +1,189 @@
1Upstream-Status: Pending
2
3Index: gcc-4_6-branch/Makefile.def
4===================================================================
5--- gcc-4_6-branch.orig/Makefile.def 2012-03-03 01:08:03.000000000 -0800
6+++ gcc-4_6-branch/Makefile.def 2012-03-04 09:19:02.430607447 -0800
7@@ -242,6 +242,7 @@
8 flags_to_pass = { flag= BISON ; };
9 flags_to_pass = { flag= CC_FOR_BUILD ; };
10 flags_to_pass = { flag= CFLAGS_FOR_BUILD ; };
11+flags_to_pass = { flag= CPPFLAGS_FOR_BUILD ; };
12 flags_to_pass = { flag= CXX_FOR_BUILD ; };
13 flags_to_pass = { flag= EXPECT ; };
14 flags_to_pass = { flag= FLEX ; };
15Index: gcc-4_6-branch/gcc/Makefile.in
16===================================================================
17--- gcc-4_6-branch.orig/gcc/Makefile.in 2012-03-03 01:03:17.000000000 -0800
18+++ gcc-4_6-branch/gcc/Makefile.in 2012-03-04 09:19:02.430607447 -0800
19@@ -770,7 +770,7 @@
20
21 # Native linker and preprocessor flags. For x-fragment overrides.
22 BUILD_LDFLAGS=@BUILD_LDFLAGS@
23-BUILD_CPPFLAGS=$(ALL_CPPFLAGS)
24+BUILD_CPPFLAGS=$(INCLUDES) @BUILD_CPPFLAGS@ $(X_CPPFLAGS)
25
26 # Actual name to use when installing a native compiler.
27 GCC_INSTALL_NAME := $(shell echo gcc|sed '$(program_transform_name)')
28Index: gcc-4_6-branch/gcc/configure.ac
29===================================================================
30--- gcc-4_6-branch.orig/gcc/configure.ac 2012-03-03 01:17:45.000000000 -0800
31+++ gcc-4_6-branch/gcc/configure.ac 2012-03-04 09:19:02.430607447 -0800
32@@ -1774,16 +1774,18 @@
33 # Also, we cannot run fixincludes.
34
35 # These are the normal (build=host) settings:
36-CC_FOR_BUILD='$(CC)' AC_SUBST(CC_FOR_BUILD)
37-BUILD_CFLAGS='$(ALL_CFLAGS)' AC_SUBST(BUILD_CFLAGS)
38-BUILD_LDFLAGS='$(LDFLAGS)' AC_SUBST(BUILD_LDFLAGS)
39-STMP_FIXINC=stmp-fixinc AC_SUBST(STMP_FIXINC)
40+CC_FOR_BUILD='$(CC)' AC_SUBST(CC_FOR_BUILD)
41+BUILD_CFLAGS='$(ALL_CFLAGS)' AC_SUBST(BUILD_CFLAGS)
42+BUILD_LDFLAGS='$(LDFLAGS)' AC_SUBST(BUILD_LDFLAGS)
43+BUILD_CPPFLAGS='$(ALL_CPPFLAGS)' AC_SUBST(BUILD_CPPFLAGS)
44+STMP_FIXINC=stmp-fixinc AC_SUBST(STMP_FIXINC)
45
46 # And these apply if build != host, or we are generating coverage data
47 if test x$build != x$host || test "x$coverage_flags" != x
48 then
49 BUILD_CFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)'
50 BUILD_LDFLAGS='$(LDFLAGS_FOR_BUILD)'
51+ BUILD_CPPFLAGS='$(CPPFLAGS_FOR_BUILD)'
52 fi
53
54 # Expand extra_headers to include complete path.
55Index: gcc-4_6-branch/Makefile.in
56===================================================================
57--- gcc-4_6-branch.orig/Makefile.in 2012-03-03 01:08:03.000000000 -0800
58+++ gcc-4_6-branch/Makefile.in 2012-03-04 09:19:02.446607448 -0800
59@@ -338,6 +338,7 @@
60 AS_FOR_BUILD = @AS_FOR_BUILD@
61 CC_FOR_BUILD = @CC_FOR_BUILD@
62 CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@
63+CPPFLAGS_FOR_BUILD = @CPPFLAGS_FOR_BUILD@
64 CXXFLAGS_FOR_BUILD = @CXXFLAGS_FOR_BUILD@
65 CXX_FOR_BUILD = @CXX_FOR_BUILD@
66 DLLTOOL_FOR_BUILD = @DLLTOOL_FOR_BUILD@
67@@ -691,6 +692,7 @@
68 "BISON=$(BISON)" \
69 "CC_FOR_BUILD=$(CC_FOR_BUILD)" \
70 "CFLAGS_FOR_BUILD=$(CFLAGS_FOR_BUILD)" \
71+ "CPPFLAGS_FOR_BUILD=$(CPPFLAGS_FOR_BUILD)" \
72 "CXX_FOR_BUILD=$(CXX_FOR_BUILD)" \
73 "EXPECT=$(EXPECT)" \
74 "FLEX=$(FLEX)" \
75Index: gcc-4_6-branch/gcc/configure
76===================================================================
77--- gcc-4_6-branch.orig/gcc/configure 2012-03-03 01:17:45.000000000 -0800
78+++ gcc-4_6-branch/gcc/configure 2012-03-04 09:19:15.638608087 -0800
79@@ -703,6 +703,7 @@
80 LIBTOOL
81 collect2
82 STMP_FIXINC
83+BUILD_CPPFLAGS
84 BUILD_LDFLAGS
85 BUILD_CFLAGS
86 CC_FOR_BUILD
87@@ -4842,7 +4843,7 @@
88 { $as_echo "$as_me:${as_lineno-$LINENO}: result: $acx_cv_cc_gcc_supports_ada" >&5
89 $as_echo "$acx_cv_cc_gcc_supports_ada" >&6; }
90
91-if test x$GNATBIND != xno && test x$GNATMAKE != xno && test x$acx_cv_cc_gcc_supports_ada != xno; then
92+if test "x$GNATBIND" != xno && test "x$GNATMAKE" != xno && test x$acx_cv_cc_gcc_supports_ada != xno; then
93 have_gnat=yes
94 else
95 have_gnat=no
96@@ -11372,6 +11373,7 @@
97 CC_FOR_BUILD='$(CC)'
98 BUILD_CFLAGS='$(ALL_CFLAGS)'
99 BUILD_LDFLAGS='$(LDFLAGS)'
100+BUILD_CPPFLAGS='$(ALL_CPPFLAGS)'
101 STMP_FIXINC=stmp-fixinc
102
103 # And these apply if build != host, or we are generating coverage data
104@@ -11379,6 +11381,7 @@
105 then
106 BUILD_CFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)'
107 BUILD_LDFLAGS='$(LDFLAGS_FOR_BUILD)'
108+ BUILD_CPPFLAGS='$(CPPFLAGS_FOR_BUILD)'
109 fi
110
111 # Expand extra_headers to include complete path.
112@@ -17495,7 +17498,7 @@
113 lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
114 lt_status=$lt_dlunknown
115 cat > conftest.$ac_ext <<_LT_EOF
116-#line 17498 "configure"
117+#line 17501 "configure"
118 #include "confdefs.h"
119
120 #if HAVE_DLFCN_H
121@@ -17601,7 +17604,7 @@
122 lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
123 lt_status=$lt_dlunknown
124 cat > conftest.$ac_ext <<_LT_EOF
125-#line 17604 "configure"
126+#line 17607 "configure"
127 #include "confdefs.h"
128
129 #if HAVE_DLFCN_H
130Index: gcc-4_6-branch/Makefile.tpl
131===================================================================
132--- gcc-4_6-branch.orig/Makefile.tpl 2012-03-03 01:08:03.000000000 -0800
133+++ gcc-4_6-branch/Makefile.tpl 2012-03-04 09:19:02.454607448 -0800
134@@ -341,6 +341,7 @@
135 AS_FOR_BUILD = @AS_FOR_BUILD@
136 CC_FOR_BUILD = @CC_FOR_BUILD@
137 CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@
138+CPPFLAGS_FOR_BUILD = @CPPFLAGS_FOR_BUILD@
139 CXXFLAGS_FOR_BUILD = @CXXFLAGS_FOR_BUILD@
140 CXX_FOR_BUILD = @CXX_FOR_BUILD@
141 DLLTOOL_FOR_BUILD = @DLLTOOL_FOR_BUILD@
142Index: gcc-4_6-branch/configure.ac
143===================================================================
144--- gcc-4_6-branch.orig/configure.ac 2012-03-03 01:17:45.000000000 -0800
145+++ gcc-4_6-branch/configure.ac 2012-03-04 09:19:02.454607448 -0800
146@@ -3123,6 +3123,7 @@
147 # our build compiler if desired.
148 if test x"${build}" = x"${host}" ; then
149 CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}}
150+ CPPFLAGS_FOR_BUILD=${CPPFLAGS_FOR_BUILD-${CPPFLAGS}}
151 CXXFLAGS_FOR_BUILD=${CXXFLAGS_FOR_BUILD-${CXXFLAGS}}
152 LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}}
153 fi
154@@ -3189,6 +3190,7 @@
155 AC_SUBST(AS_FOR_BUILD)
156 AC_SUBST(CC_FOR_BUILD)
157 AC_SUBST(CFLAGS_FOR_BUILD)
158+AC_SUBST(CPPFLAGS_FOR_BUILD)
159 AC_SUBST(CXXFLAGS_FOR_BUILD)
160 AC_SUBST(CXX_FOR_BUILD)
161 AC_SUBST(DLLTOOL_FOR_BUILD)
162Index: gcc-4_6-branch/configure
163===================================================================
164--- gcc-4_6-branch.orig/configure 2012-03-03 01:17:45.000000000 -0800
165+++ gcc-4_6-branch/configure 2012-03-04 09:19:02.458607448 -0800
166@@ -617,6 +617,7 @@
167 DLLTOOL_FOR_BUILD
168 CXX_FOR_BUILD
169 CXXFLAGS_FOR_BUILD
170+CPPFLAGS_FOR_BUILD
171 CFLAGS_FOR_BUILD
172 CC_FOR_BUILD
173 AS_FOR_BUILD
174@@ -7644,6 +7645,7 @@
175 # our build compiler if desired.
176 if test x"${build}" = x"${host}" ; then
177 CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}}
178+ CPPFLAGS_FOR_BUILD=${CPPFLAGS_FOR_BUILD-${CPPFLAGS}}
179 CXXFLAGS_FOR_BUILD=${CXXFLAGS_FOR_BUILD-${CXXFLAGS}}
180 LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}}
181 fi
182@@ -7709,6 +7711,7 @@
183
184
185
186+
187
188
189