summaryrefslogtreecommitdiffstats
path: root/toolchain-layer/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain-layer/conf/layer.conf')
-rw-r--r--toolchain-layer/conf/layer.conf30
1 files changed, 30 insertions, 0 deletions
diff --git a/toolchain-layer/conf/layer.conf b/toolchain-layer/conf/layer.conf
new file mode 100644
index 000000000..b377f1236
--- /dev/null
+++ b/toolchain-layer/conf/layer.conf
@@ -0,0 +1,30 @@
1# It really depends on order of the layers appearing in BBLAYERS
2# variable in toplevel bblayers.conf file, where bitbake will search
3# for .inc files and others where bitbake uses BBPATH since it will
4# search the directories from first to last as specified in BBPATH
5# Therefore if you want a given layer to be considered high priority
6# for the .inc and .conf etc. then consider it adding at the beginning
7# of BBPATH. For bblayers bitbake will use BBFILES_PRIORITY to resolve
8# the recipe contention so the order of directories in BBFILES does
9# not matter.
10
11# We have a conf directory, append to BBPATH
12BBPATH .= ":${LAYERDIR}"
13
14# We have a recipes directory, add to BBFILES
15BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
16
17BBFILE_COLLECTIONS += "toolchain-layer"
18BBFILE_PATTERN_toolchain-layer := "^${LAYERDIR}/"
19
20# Define the priority for recipes (.bb files) from this layer,
21# choosing carefully how this layer interacts with all of the
22# other layers.
23
24BBFILE_PRIORITY_toolchain-layer = "6"
25
26# This should only be incremented on significant changes that will
27# cause compatibility issues with other layers
28LAYERVERSION_toolchain-layer = "1"
29
30LAYERDEPENDS_toolchain-layer = "core"