summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.12.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/xfwm4/xfwm4_4.12.4.bb')
-rw-r--r--meta-xfce/recipes-xfce/xfwm4/xfwm4_4.12.4.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.12.4.bb b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.12.4.bb
new file mode 100644
index 000000000..2aa68e3fd
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.12.4.bb
@@ -0,0 +1,30 @@
1DESCRIPTION="Xfce4 Window Manager"
2SECTION = "x11/wm"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d791728a073bc009b4ffaf00b7599855"
5DEPENDS = "virtual/libx11 libxpm gtk+ libxfce4util libxfce4ui xfconf libwnck dbus-glib startup-notification exo-native"
6
7inherit xfce update-alternatives distro_features_check
8
9REQUIRED_DISTRO_FEATURES = "x11"
10
11SRC_URI[md5sum] = "3ec136efc5387fd3b53cd66b684f52d7"
12SRC_URI[sha256sum] = "fa74048a75649a6e92df763a3cfb706d3fed1e1a6adf567f6693325a5a6efb36"
13
14python populate_packages_prepend () {
15 themedir = d.expand('${datadir}/themes')
16 do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'XFWM4 theme %s', allow_dirs=True)
17}
18
19PACKAGES_DYNAMIC += "^xfwm4-theme-.*"
20
21ALTERNATIVE_${PN} = "x-window-manager"
22ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/xfwm4"
23ALTERNATIVE_PRIORITY[x-window-manager] = "30"
24
25RDEPENDS_${PN} = "xfwm4-theme-default"
26FILES_${PN} += "${libdir}/xfce4/xfwm4/helper-dialog \
27 ${datadir}/xfwm4/defaults \
28"
29FILES_${PN}-dbg += "${libexecdir}/xfce4/xfwm4/.debug/*"
30