summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/tumbler/tumbler_4.20.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/tumbler/tumbler_4.20.0.bb')
-rw-r--r--meta-xfce/recipes-xfce/tumbler/tumbler_4.20.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/tumbler/tumbler_4.20.0.bb b/meta-xfce/recipes-xfce/tumbler/tumbler_4.20.0.bb
new file mode 100644
index 0000000000..6c5fce535c
--- /dev/null
+++ b/meta-xfce/recipes-xfce/tumbler/tumbler_4.20.0.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "Thumbnail service implementing the thumbnail management D-Bus specification"
2SECTION = "x11/libs"
3LICENSE = "GPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5DEPENDS = "freetype gdk-pixbuf poppler curl xfce4-dev-tools-native libxml2 libgsf libxfce4util"
6
7inherit xfce gtk-doc systemd
8
9SRC_URI[sha256sum] = "74b1647d55926547e98bfac70838ff63c5a84299a5e10c81c38d1fab90e25880"
10
11INSANE_SKIP:${PN} = "dev-so"
12
13PACKAGECONFIG ??= ""
14PACKAGECONFIG[gstreamer-thumbnailer] = "--enable-gstreamer-thumbnailer,--disable-gstreamer-thumbnailer,gstreamer1.0 gstreamer1.0-plugins-base"
15
16EXTRA_OECONF = "GDBUS_CODEGEN=${STAGING_BINDIR_NATIVE}/gdbus-codegen"
17
18do_install:append() {
19 # Makefile seems to race on creation of symlink. So ensure creation here
20 # until fixed properly
21 ln -sf tumbler-xdg-cache.so ${D}${libdir}/tumbler-1/plugins/cache/tumbler-cache-plugin.so
22}
23
24FILES:${PN} += "${datadir}/dbus-1/services \
25 ${libdir}/tumbler-1/tumblerd \
26 ${libdir}/tumbler-1/plugins/*.so \
27 ${libdir}/tumbler-1/plugins/cache/*.so \
28 ${systemd_user_unitdir}/tumblerd.service \
29"
30
31FILES:${PN}-dev += "${libdir}/tumbler-1/plugins/*.la \
32 ${libdir}/tumbler-1/plugins/cache/*.la \
33"