summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/exo/exo_0.12.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/exo/exo_0.12.0.bb')
-rw-r--r--meta-xfce/recipes-xfce/exo/exo_0.12.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/exo/exo_0.12.0.bb b/meta-xfce/recipes-xfce/exo/exo_0.12.0.bb
new file mode 100644
index 000000000..d256b5769
--- /dev/null
+++ b/meta-xfce/recipes-xfce/exo/exo_0.12.0.bb
@@ -0,0 +1,39 @@
1DESCRIPTION="Application library for the Xfce desktop environment"
2SECTION = "x11"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5DEPENDS = "gtk+ libxfce4util libxfce4ui virtual/libx11 liburi-perl-native cairo"
6DEPENDS_class-native = "glib-2.0-native xfce4-dev-tools-native intltool-native"
7
8inherit xfce pythonnative perlnative gtk-doc distro_features_check
9
10REQUIRED_DISTRO_FEATURES = "x11"
11REQUIRED_DISTRO_FEATURES_class-native = ""
12
13# SRC_URI must follow inherited one
14SRC_URI += " \
15 file://exo-no-tests-0.8.patch \
16 file://configure.patch \
17"
18
19SRC_URI_append_class-native = " \
20 file://reduce-build-to-exo-csource-only.patch \
21"
22
23SRC_URI[md5sum] = "724afcca224f5fb22b510926d2740e52"
24SRC_URI[sha256sum] = "64b88271a37d0ec7dca062c7bc61ca323116f7855092ac39698c421a2f30a18f"
25
26PACKAGES =+ "exo-csource"
27
28# Note: python bindings did not work in oe-dev and are about to be moved to
29# pyxfce see http://comments.gmane.org/gmane.comp.desktop.xfce.devel.version4/19560
30FILES_${PN} += "${datadir}/xfce4/ \
31 ${libdir}/xfce4/exo-1 \
32"
33
34FILES_${PN}-dbg += "${libdir}/gio/modules/.debug \
35"
36
37FILES_exo-csource += "${bindir}/exo-csource"
38
39BBCLASSEXTEND = "native"