summaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-apps/menulibre/menulibre_2.1.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-apps/menulibre/menulibre_2.1.5.bb')
-rw-r--r--meta-xfce/recipes-apps/menulibre/menulibre_2.1.5.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-xfce/recipes-apps/menulibre/menulibre_2.1.5.bb b/meta-xfce/recipes-apps/menulibre/menulibre_2.1.5.bb
new file mode 100644
index 000000000..cc7b29164
--- /dev/null
+++ b/meta-xfce/recipes-apps/menulibre/menulibre_2.1.5.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "An advanced menu editor"
2HOMEPAGE = "https://launchpad.net/menulibre"
3SECTION = "x11/graphics"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7DEPENDS = " \
8 python3-distutils-extra-native \
9 intltool-native \
10"
11
12inherit distutils3 gtk-icon-cache
13
14SRC_URI = "https://launchpad.net/menulibre/2.1/${PV}/+download/${PN}-${PV}.tar.gz"
15SRC_URI[md5sum] = "efc7edb49bb0e5fea49e158b40573334"
16SRC_URI[sha256sum] = "ef05b2722bab2acb7070d6c8ed0e7bd58bd4a4540bf498af9e889944f9da08b5"
17
18do_compile() {
19}
20
21do_install_append() {
22 sed -i 's:${D}::g' ${D}${datadir}/applications/menulibre.desktop
23 sed -i 's:share/share:share:g' ${D}${PYTHON_SITEPACKAGES_DIR}/menulibre_lib/menulibreconfig.py
24}
25
26FILES_${PN} += " \
27 ${datadir}/applications \
28 ${datadir}/menulibre \
29 ${datadir}/icons \
30"
31
32RDEPENDS_${PN} += " \
33 gtk+3 \
34 gtksourceview3 \
35 python3-pygobject \
36 gnome-menus3 \
37 python3-unixadmin \
38 python3-psutil \
39"