summaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/conf/layer.conf2
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.59.bb45
-rw-r--r--meta-webserver/recipes-httpd/cherokee/cherokee_git.bb4
-rw-r--r--meta-webserver/recipes-httpd/hiawatha/hiawatha_10.12.bb6
-rw-r--r--meta-webserver/recipes-httpd/monkey/monkey_1.6.9.bb4
-rw-r--r--meta-webserver/recipes-httpd/nginx/nginx.inc12
-rw-r--r--meta-webserver/recipes-httpd/sthttpd/sthttpd_2.27.1.bb6
-rw-r--r--meta-webserver/recipes-php/phpmyadmin/phpmyadmin_5.2.1.bb2
-rw-r--r--meta-webserver/recipes-webadmin/cockpit/cockpit_304.bb2
-rw-r--r--meta-webserver/recipes-webadmin/netdata/netdata_1.44.3.bb4
-rw-r--r--meta-webserver/recipes-webadmin/webmin/webmin_1.850.bb4
11 files changed, 50 insertions, 41 deletions
diff --git a/meta-webserver/conf/layer.conf b/meta-webserver/conf/layer.conf
index 717bfda47..08e9df505 100644
--- a/meta-webserver/conf/layer.conf
+++ b/meta-webserver/conf/layer.conf
@@ -17,7 +17,7 @@ LAYERVERSION_webserver = "1"
17 17
18LAYERDEPENDS_webserver = "core openembedded-layer" 18LAYERDEPENDS_webserver = "core openembedded-layer"
19 19
20LAYERSERIES_COMPAT_webserver = "scarthgap styhead" 20LAYERSERIES_COMPAT_webserver = "styhead"
21 21
22LICENSE_PATH += "${LAYERDIR}/licenses" 22LICENSE_PATH += "${LAYERDIR}/licenses"
23 23
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.59.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.59.bb
index b96e8b4e1..1632c6ccb 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.59.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.59.bb
@@ -31,7 +31,7 @@ SRC_URI[sha256sum] = "ec51501ec480284ff52f637258135d333230a7d229c3afa6f6c2f9040e
31 31
32S = "${WORKDIR}/httpd-${PV}" 32S = "${WORKDIR}/httpd-${PV}"
33 33
34inherit autotools update-rc.d pkgconfig systemd update-alternatives 34inherit autotools update-rc.d pkgconfig systemd multilib_script multilib_header
35 35
36DEPENDS = "openssl expat pcre apr apr-util apache2-native " 36DEPENDS = "openssl expat pcre apr apr-util apache2-native "
37 37
@@ -80,13 +80,15 @@ EXTRA_OECONF:class-native = "\
80 " 80 "
81 81
82do_configure:prepend() { 82do_configure:prepend() {
83 sed -i -e 's:$''{prefix}/usr/lib/cgi-bin:$''{libexecdir}/cgi-bin:g' ${S}/config.layout 83 sed -i -e 's:$''{prefix}/usr/lib/cgi-bin:$''{libexecdir}/cgi-bin:g' \
84 -e 's#\(installbuilddir:\s*\).*#\1${libexecdir}/${PN}/build#' \
85 ${S}/config.layout
84} 86}
85 87
86do_install:append:class-target() { 88do_install:append:class-target() {
87 install -d ${D}/${sysconfdir}/init.d 89 install -d ${D}/${sysconfdir}/init.d
88 90
89 cat ${WORKDIR}/init | \ 91 cat ${UNPACKDIR}/init | \
90 sed -e 's,/usr/sbin/,${sbindir}/,g' \ 92 sed -e 's,/usr/sbin/,${sbindir}/,g' \
91 -e 's,/usr/bin/,${bindir}/,g' \ 93 -e 's,/usr/bin/,${bindir}/,g' \
92 -e 's,/usr/lib/,${libdir}/,g' \ 94 -e 's,/usr/lib/,${libdir}/,g' \
@@ -119,30 +121,33 @@ do_install:append:class-target() {
119 -e 's,-fdebug-prefix-map[^ ]*,,g; s,-fmacro-prefix-map[^ ]*,,g; s,-ffile-prefix-map[^ ]*,,g' \ 121 -e 's,-fdebug-prefix-map[^ ]*,,g; s,-fmacro-prefix-map[^ ]*,,g; s,-ffile-prefix-map[^ ]*,,g' \
120 -e 's,${HOSTTOOLS_DIR}/,,g' \ 122 -e 's,${HOSTTOOLS_DIR}/,,g' \
121 -e 's,APU_INCLUDEDIR = .*,APU_INCLUDEDIR = ,g' \ 123 -e 's,APU_INCLUDEDIR = .*,APU_INCLUDEDIR = ,g' \
122 -e 's,APU_CONFIG = .*,APU_CONFIG = ,g' ${D}${datadir}/apache2/build/config_vars.mk 124 -e 's,APU_CONFIG = .*,APU_CONFIG = ,g' ${D}${libexecdir}/${PN}/build/config_vars.mk
123 125
124 sed -i -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \ 126 sed -i -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
125 -e 's,${DEBUG_PREFIX_MAP},,g' \ 127 -e 's,${DEBUG_PREFIX_MAP},,g' \
126 -e 's,${RECIPE_SYSROOT},,g' \ 128 -e 's,${RECIPE_SYSROOT},,g' \
127 -e 's,-fdebug-prefix-map[^ ]*,,g; s,-fmacro-prefix-map[^ ]*,,g; s,-fmacro-prefix-map[^ ]*,,g' \ 129 -e 's,-fdebug-prefix-map[^ ]*,,g; s,-fmacro-prefix-map[^ ]*,,g; s,-fmacro-prefix-map[^ ]*,,g' \
128 -e 's,APU_INCLUDEDIR = .*,APU_INCLUDEDIR = ,g' \ 130 -e 's,APU_INCLUDEDIR = .*,APU_INCLUDEDIR = ,g' \
129 -e 's,".*/configure","configure",g' ${D}${datadir}/apache2/build/config.nice 131 -e 's,${WORKDIR}/recipe-sysroot/,,g' \
132 -e 's,".*/configure","configure",g' ${D}${libexecdir}/${PN}/build/config.nice
130 133
131 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 134 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
132 install -d ${D}${sysconfdir}/tmpfiles.d/ 135 install -d ${D}${sysconfdir}/tmpfiles.d/
133 install -m 0644 ${WORKDIR}/apache2-volatile.conf ${D}${sysconfdir}/tmpfiles.d/ 136 install -m 0644 ${UNPACKDIR}/apache2-volatile.conf ${D}${sysconfdir}/tmpfiles.d/
134 137
135 install -d ${D}${systemd_unitdir}/system 138 install -d ${D}${systemd_unitdir}/system
136 install -m 0644 ${WORKDIR}/apache2.service ${D}${systemd_unitdir}/system 139 install -m 0644 ${UNPACKDIR}/apache2.service ${D}${systemd_unitdir}/system
137 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/apache2.service 140 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/apache2.service
138 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' ${D}${systemd_unitdir}/system/apache2.service 141 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' ${D}${systemd_unitdir}/system/apache2.service
139 elif ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 142 elif ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
140 install -d ${D}${sysconfdir}/default/volatiles 143 install -d ${D}${sysconfdir}/default/volatiles
141 install -m 0644 ${WORKDIR}/volatiles.04_apache2 ${D}${sysconfdir}/default/volatiles/04_apache2 144 install -m 0644 ${UNPACKDIR}/volatiles.04_apache2 ${D}${sysconfdir}/default/volatiles/04_apache2
142 fi 145 fi
143 146
144 rm -rf ${D}${localstatedir} ${D}${sbindir}/envvars* 147 rm -rf ${D}${localstatedir} ${D}${sbindir}/envvars*
145 chown -R root:root ${D} 148 chown -R root:root ${D}
149
150 oe_multilib_header apache2/ap_config_layout.h
146} 151}
147 152
148do_install:append:class-native() { 153do_install:append:class-native() {
@@ -152,20 +157,22 @@ do_install:append:class-native() {
152 157
153SYSROOT_PREPROCESS_FUNCS:append:class-target = " apache_sysroot_preprocess" 158SYSROOT_PREPROCESS_FUNCS:append:class-target = " apache_sysroot_preprocess"
154 159
160SYSROOT_DIRS += "${libexecdir}/${PN}/build"
161
155apache_sysroot_preprocess() { 162apache_sysroot_preprocess() {
156 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts} 163 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}
157 install -m 755 ${D}${bindir}/apxs ${SYSROOT_DESTDIR}${bindir_crossscripts} 164 install -m 755 ${D}${bindir}/apxs ${SYSROOT_DESTDIR}${bindir_crossscripts}
158 install -d ${SYSROOT_DESTDIR}${sbindir} 165 install -d ${SYSROOT_DESTDIR}${sbindir}
159 install -m 755 ${D}${sbindir}/apachectl ${SYSROOT_DESTDIR}${sbindir} 166 install -m 755 ${D}${sbindir}/apachectl ${SYSROOT_DESTDIR}${sbindir}
160 sed -i 's!my $installbuilddir = .*!my $installbuilddir = "${STAGING_DIR_HOST}/${datadir}/${BPN}/build";!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/apxs 167 sed -i 's!\(my $installbuilddir = \)"\(.*\)"!\1"${STAGING_DIR_HOST}\2"!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/apxs
161 168
162 sed -i 's!^APR_CONFIG = .*!APR_CONFIG = ${STAGING_BINDIR_CROSS}/apr-1-config!' ${SYSROOT_DESTDIR}${datadir}/${BPN}/build/config_vars.mk 169 sed -i 's!^APR_CONFIG = .*!APR_CONFIG = ${STAGING_BINDIR_CROSS}/apr-1-config!' ${SYSROOT_DESTDIR}${libexecdir}/${PN}/build/config_vars.mk
163 sed -i 's!^APU_CONFIG = .*!APU_CONFIG = ${STAGING_BINDIR_CROSS}/apu-1-config!' ${SYSROOT_DESTDIR}${datadir}/${BPN}/build/config_vars.mk 170 sed -i 's!^APU_CONFIG = .*!APU_CONFIG = ${STAGING_BINDIR_CROSS}/apu-1-config!' ${SYSROOT_DESTDIR}${libexecdir}/${PN}/build/config_vars.mk
164 sed -i 's!^includedir = .*!includedir = ${STAGING_INCDIR}/apache2!' ${SYSROOT_DESTDIR}${datadir}/${BPN}/build/config_vars.mk 171 sed -i 's!^includedir = .*!includedir = ${STAGING_INCDIR}/apache2!' ${SYSROOT_DESTDIR}${libexecdir}/${PN}/build/config_vars.mk
165 sed -i 's!^CFLAGS = -I[^ ]*!CFLAGS = -I${STAGING_INCDIR}/openssl!' ${SYSROOT_DESTDIR}${datadir}/${BPN}/build/config_vars.mk 172 sed -i 's!^CFLAGS = -I[^ ]*!CFLAGS = -I${STAGING_INCDIR}/openssl!' ${SYSROOT_DESTDIR}${libexecdir}/${PN}/build/config_vars.mk
166 sed -i 's!^EXTRA_LDFLAGS = .*!EXTRA_LDFLAGS = -L${STAGING_LIBDIR}!' ${SYSROOT_DESTDIR}${datadir}/${BPN}/build/config_vars.mk 173 sed -i 's!^EXTRA_LDFLAGS = .*!EXTRA_LDFLAGS = -L${STAGING_LIBDIR}!' ${SYSROOT_DESTDIR}${libexecdir}/${PN}/build/config_vars.mk
167 sed -i 's!^EXTRA_INCLUDES = .*!EXTRA_INCLUDES = -I$(includedir) -I. -I${STAGING_INCDIR}!' ${SYSROOT_DESTDIR}${datadir}/${BPN}/build/config_vars.mk 174 sed -i 's!^EXTRA_INCLUDES = .*!EXTRA_INCLUDES = -I$(includedir) -I. -I${STAGING_INCDIR}!' ${SYSROOT_DESTDIR}${libexecdir}/${PN}/build/config_vars.mk
168 sed -i 's!--sysroot=[^ ]*!--sysroot=${STAGING_DIR_HOST}!' ${SYSROOT_DESTDIR}${datadir}/${BPN}/build/config_vars.mk 175 sed -i 's!--sysroot=[^ ]*!--sysroot=${STAGING_DIR_HOST}!' ${SYSROOT_DESTDIR}${libexecdir}/${PN}/build/config_vars.mk
169} 176}
170 177
171# Implications - used by update-rc.d scripts 178# Implications - used by update-rc.d scripts
@@ -178,6 +185,8 @@ SYSTEMD_AUTO_ENABLE:${PN} = "enable"
178ALTERNATIVE:${PN}-doc = "htpasswd.1" 185ALTERNATIVE:${PN}-doc = "htpasswd.1"
179ALTERNATIVE_LINK_NAME[htpasswd.1] = "${mandir}/man1/htpasswd.1" 186ALTERNATIVE_LINK_NAME[htpasswd.1] = "${mandir}/man1/htpasswd.1"
180 187
188MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/apxs"
189
181PACKAGES = "${PN}-utils ${PN}-scripts ${PN}-doc ${PN}-dev ${PN}-dbg ${PN}" 190PACKAGES = "${PN}-utils ${PN}-scripts ${PN}-doc ${PN}-dev ${PN}-dbg ${PN}"
182 191
183CONFFILES:${PN} = "${sysconfdir}/${BPN}/httpd.conf \ 192CONFFILES:${PN} = "${sysconfdir}/${BPN}/httpd.conf \
@@ -200,7 +209,7 @@ FILES:${PN}-utils = "${bindir}/ab \
200# We override here rather than append so that .so links are 209# We override here rather than append so that .so links are
201# included in the runtime package rather than here (-dev) 210# included in the runtime package rather than here (-dev)
202# and to get build, icons, error into the -dev package 211# and to get build, icons, error into the -dev package
203FILES:${PN}-dev = "${datadir}/${BPN}/build \ 212FILES:${PN}-dev = "${libexecdir}/${PN}/build \
204 ${datadir}/${BPN}/icons \ 213 ${datadir}/${BPN}/icons \
205 ${datadir}/${BPN}/error \ 214 ${datadir}/${BPN}/error \
206 ${includedir}/${BPN} \ 215 ${includedir}/${BPN} \
diff --git a/meta-webserver/recipes-httpd/cherokee/cherokee_git.bb b/meta-webserver/recipes-httpd/cherokee/cherokee_git.bb
index 7763a3188..53d6a85ae 100644
--- a/meta-webserver/recipes-httpd/cherokee/cherokee_git.bb
+++ b/meta-webserver/recipes-httpd/cherokee/cherokee_git.bb
@@ -36,13 +36,13 @@ EXTRA_OECONF = "--disable-static \
36 36
37do_install:append () { 37do_install:append () {
38 install -m 0755 -d ${D}${sysconfdir}/init.d 38 install -m 0755 -d ${D}${sysconfdir}/init.d
39 install -m 755 ${WORKDIR}/cherokee.init ${D}${sysconfdir}/init.d/cherokee 39 install -m 755 ${UNPACKDIR}/cherokee.init ${D}${sysconfdir}/init.d/cherokee
40 40
41 # clean up .la files for plugins 41 # clean up .la files for plugins
42 rm -f ${D}${libdir}/cherokee/*.la 42 rm -f ${D}${libdir}/cherokee/*.la
43 43
44 install -d ${D}${systemd_unitdir}/system 44 install -d ${D}${systemd_unitdir}/system
45 install -m 0644 ${WORKDIR}/cherokee.service ${D}${systemd_unitdir}/system 45 install -m 0644 ${UNPACKDIR}/cherokee.service ${D}${systemd_unitdir}/system
46 rmdir "${D}${localstatedir}/run" 46 rmdir "${D}${localstatedir}/run"
47 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" 47 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
48} 48}
diff --git a/meta-webserver/recipes-httpd/hiawatha/hiawatha_10.12.bb b/meta-webserver/recipes-httpd/hiawatha/hiawatha_10.12.bb
index 2e848eaf5..1111ef6f5 100644
--- a/meta-webserver/recipes-httpd/hiawatha/hiawatha_10.12.bb
+++ b/meta-webserver/recipes-httpd/hiawatha/hiawatha_10.12.bb
@@ -37,9 +37,9 @@ EXTRA_OECMAKE = " -DENABLE_IPV6=OFF \
37 37
38do_install:append() { 38do_install:append() {
39 # Copy over init script and sed in the correct sbin path 39 # Copy over init script and sed in the correct sbin path
40 sed -i 's,sed_sbin_path,${sbindir},' ${WORKDIR}/hiawatha-init 40 sed -i 's,sed_sbin_path,${sbindir},' ${UNPACKDIR}/hiawatha-init
41 mkdir -p ${D}${sysconfdir}/init.d 41 mkdir -p ${D}${sysconfdir}/init.d
42 install -m 0755 ${WORKDIR}/hiawatha-init ${D}${sysconfdir}/init.d/hiawatha 42 install -m 0755 ${UNPACKDIR}/hiawatha-init ${D}${sysconfdir}/init.d/hiawatha
43 43
44 # configure php-fcgi to have a working configuration 44 # configure php-fcgi to have a working configuration
45 # by default if php is installed 45 # by default if php is installed
@@ -47,7 +47,7 @@ do_install:append() {
47 47
48 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then 48 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
49 install -d ${D}/${systemd_unitdir}/system 49 install -d ${D}/${systemd_unitdir}/system
50 install -m 644 ${WORKDIR}/hiawatha.service ${D}/${systemd_unitdir}/system 50 install -m 644 ${UNPACKDIR}/hiawatha.service ${D}/${systemd_unitdir}/system
51 fi 51 fi
52 52
53 # /var/log/hiawatha and /var/lib/hiawatha needs to be created in runtime. 53 # /var/log/hiawatha and /var/lib/hiawatha needs to be created in runtime.
diff --git a/meta-webserver/recipes-httpd/monkey/monkey_1.6.9.bb b/meta-webserver/recipes-httpd/monkey/monkey_1.6.9.bb
index ee5dc1619..5bf6373a8 100644
--- a/meta-webserver/recipes-httpd/monkey/monkey_1.6.9.bb
+++ b/meta-webserver/recipes-httpd/monkey/monkey_1.6.9.bb
@@ -46,7 +46,7 @@ do_configure:append() {
46do_install:append() { 46do_install:append() {
47 rmdir ${D}${localstatedir}/log/${BPN} ${D}${localstatedir}/run ${D}${localstatedir}/log 47 rmdir ${D}${localstatedir}/log/${BPN} ${D}${localstatedir}/run ${D}${localstatedir}/log
48 rmdir --ignore-fail-on-non-empty ${D}${localstatedir} 48 rmdir --ignore-fail-on-non-empty ${D}${localstatedir}
49 install -Dm 0755 ${WORKDIR}/monkey.init ${D}${sysconfdir}/init.d/monkey 49 install -Dm 0755 ${UNPACKDIR}/monkey.init ${D}${sysconfdir}/init.d/monkey
50 # Create /var/log/monkey in runtime. 50 # Create /var/log/monkey in runtime.
51 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" ]; then 51 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" ]; then
52 install -d ${D}${nonarch_libdir}/tmpfiles.d 52 install -d ${D}${nonarch_libdir}/tmpfiles.d
@@ -57,7 +57,7 @@ do_install:append() {
57 echo "d ${BPN} ${BPN} 0755 ${localstatedir}/log/${BPN} none" > ${D}${sysconfdir}/default/volatiles/99_${BPN} 57 echo "d ${BPN} ${BPN} 0755 ${localstatedir}/log/${BPN} none" > ${D}${sysconfdir}/default/volatiles/99_${BPN}
58 fi 58 fi
59 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then 59 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
60 install -Dm 644 ${WORKDIR}/monkey.service ${D}/${systemd_unitdir}/system/monkey.service 60 install -Dm 644 ${UNPACKDIR}/monkey.service ${D}/${systemd_unitdir}/system/monkey.service
61 fi 61 fi
62} 62}
63 63
diff --git a/meta-webserver/recipes-httpd/nginx/nginx.inc b/meta-webserver/recipes-httpd/nginx/nginx.inc
index 83ae90c40..2714c3d22 100644
--- a/meta-webserver/recipes-httpd/nginx/nginx.inc
+++ b/meta-webserver/recipes-httpd/nginx/nginx.inc
@@ -108,24 +108,24 @@ do_install () {
108 chown ${NGINX_USER}:www-data -R ${D}${NGINX_WWWDIR} 108 chown ${NGINX_USER}:www-data -R ${D}${NGINX_WWWDIR}
109 109
110 install -d ${D}${sysconfdir}/init.d 110 install -d ${D}${sysconfdir}/init.d
111 install -m 0755 ${WORKDIR}/nginx.init ${D}${sysconfdir}/init.d/nginx 111 install -m 0755 ${UNPACKDIR}/nginx.init ${D}${sysconfdir}/init.d/nginx
112 sed -i 's,/usr/sbin/,${sbindir}/,g' ${D}${sysconfdir}/init.d/nginx 112 sed -i 's,/usr/sbin/,${sbindir}/,g' ${D}${sysconfdir}/init.d/nginx
113 sed -i 's,/etc/,${sysconfdir}/,g' ${D}${sysconfdir}/init.d/nginx 113 sed -i 's,/etc/,${sysconfdir}/,g' ${D}${sysconfdir}/init.d/nginx
114 114
115 install -d ${D}${sysconfdir}/nginx 115 install -d ${D}${sysconfdir}/nginx
116 install -m 0644 ${WORKDIR}/nginx.conf ${D}${sysconfdir}/nginx/nginx.conf 116 install -m 0644 ${UNPACKDIR}/nginx.conf ${D}${sysconfdir}/nginx/nginx.conf
117 sed -i 's,/etc/,${sysconfdir}/,g' ${D}${sysconfdir}/nginx/nginx.conf 117 sed -i 's,/etc/,${sysconfdir}/,g' ${D}${sysconfdir}/nginx/nginx.conf
118 sed -i 's,/var/,${localstatedir}/,g' ${D}${sysconfdir}/nginx/nginx.conf 118 sed -i 's,/var/,${localstatedir}/,g' ${D}${sysconfdir}/nginx/nginx.conf
119 sed -i 's/^user.*/user ${NGINX_USER};/g' ${D}${sysconfdir}/nginx/nginx.conf 119 sed -i 's/^user.*/user ${NGINX_USER};/g' ${D}${sysconfdir}/nginx/nginx.conf
120 install -Dm 0644 ${WORKDIR}/default_server.site ${D}${sysconfdir}/nginx/sites-available/default_server 120 install -Dm 0644 ${UNPACKDIR}/default_server.site ${D}${sysconfdir}/nginx/sites-available/default_server
121 sed -i 's,/var/,${localstatedir}/,g' ${D}${sysconfdir}/nginx/sites-available/default_server 121 sed -i 's,/var/,${localstatedir}/,g' ${D}${sysconfdir}/nginx/sites-available/default_server
122 install -d ${D}${sysconfdir}/nginx/sites-enabled 122 install -d ${D}${sysconfdir}/nginx/sites-enabled
123 ln -s ../sites-available/default_server ${D}${sysconfdir}/nginx/sites-enabled/ 123 ln -s ../sites-available/default_server ${D}${sysconfdir}/nginx/sites-enabled/
124 124
125 install -m 0644 ${WORKDIR}/proxy_params ${D}${sysconfdir}/nginx/proxy_params 125 install -m 0644 ${UNPACKDIR}/proxy_params ${D}${sysconfdir}/nginx/proxy_params
126 126
127 install -d ${D}${sysconfdir}/default/volatiles 127 install -d ${D}${sysconfdir}/default/volatiles
128 install -m 0644 ${WORKDIR}/nginx-volatile.conf ${D}${sysconfdir}/default/volatiles/99_nginx 128 install -m 0644 ${UNPACKDIR}/nginx-volatile.conf ${D}${sysconfdir}/default/volatiles/99_nginx
129 sed -i 's,/var/,${localstatedir}/,g' ${D}${sysconfdir}/default/volatiles/99_nginx 129 sed -i 's,/var/,${localstatedir}/,g' ${D}${sysconfdir}/default/volatiles/99_nginx
130 sed -i 's,@NGINX_USER@,${NGINX_USER},g' ${D}${sysconfdir}/default/volatiles/99_nginx 130 sed -i 's,@NGINX_USER@,${NGINX_USER},g' ${D}${sysconfdir}/default/volatiles/99_nginx
131 131
@@ -140,7 +140,7 @@ do_install () {
140 140
141 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)};then 141 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)};then
142 install -d ${D}${systemd_unitdir}/system 142 install -d ${D}${systemd_unitdir}/system
143 install -m 0644 ${WORKDIR}/nginx.service ${D}${systemd_unitdir}/system/ 143 install -m 0644 ${UNPACKDIR}/nginx.service ${D}${systemd_unitdir}/system/
144 sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' \ 144 sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' \
145 -e 's,@LOCALSTATEDIR@,${localstatedir},g' \ 145 -e 's,@LOCALSTATEDIR@,${localstatedir},g' \
146 -e 's,@SBINDIR@,${sbindir},g' \ 146 -e 's,@SBINDIR@,${sbindir},g' \
diff --git a/meta-webserver/recipes-httpd/sthttpd/sthttpd_2.27.1.bb b/meta-webserver/recipes-httpd/sthttpd/sthttpd_2.27.1.bb
index 601ec7bcd..ec188cc48 100644
--- a/meta-webserver/recipes-httpd/sthttpd/sthttpd_2.27.1.bb
+++ b/meta-webserver/recipes-httpd/sthttpd/sthttpd_2.27.1.bb
@@ -37,14 +37,14 @@ do_configure:prepend () {
37 37
38do_install:append () { 38do_install:append () {
39 install -d ${D}${sysconfdir}/init.d 39 install -d ${D}${sysconfdir}/init.d
40 install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/thttpd 40 install -c -m 755 ${UNPACKDIR}/init ${D}${sysconfdir}/init.d/thttpd
41 install -c -m 755 ${WORKDIR}/thttpd.conf ${D}${sysconfdir} 41 install -c -m 755 ${UNPACKDIR}/thttpd.conf ${D}${sysconfdir}
42 sed -i -e 's,@@CONFFILE,${sysconfdir}/thttpd.conf,g' ${D}${sysconfdir}/init.d/thttpd 42 sed -i -e 's,@@CONFFILE,${sysconfdir}/thttpd.conf,g' ${D}${sysconfdir}/init.d/thttpd
43 sed -i -e 's,@@SRVDIR,${SRV_DIR},g' ${D}${sysconfdir}/thttpd.conf 43 sed -i -e 's,@@SRVDIR,${SRV_DIR},g' ${D}${sysconfdir}/thttpd.conf
44 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/thttpd 44 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/thttpd
45 45
46 install -d ${D}${systemd_unitdir}/system 46 install -d ${D}${systemd_unitdir}/system
47 install -m 0644 ${WORKDIR}/thttpd.service ${D}${systemd_unitdir}/system 47 install -m 0644 ${UNPACKDIR}/thttpd.service ${D}${systemd_unitdir}/system
48 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${systemd_unitdir}/system/thttpd.service 48 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${systemd_unitdir}/system/thttpd.service
49 sed -i 's!/var/!${localstatedir}/!g' ${D}${systemd_unitdir}/system/thttpd.service 49 sed -i 's!/var/!${localstatedir}/!g' ${D}${systemd_unitdir}/system/thttpd.service
50 sed -i -e 's,@@CONFFILE,${sysconfdir}/thttpd.conf,g' ${D}${systemd_unitdir}/system/thttpd.service 50 sed -i -e 's,@@CONFFILE,${sysconfdir}/thttpd.conf,g' ${D}${systemd_unitdir}/system/thttpd.service
diff --git a/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_5.2.1.bb b/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_5.2.1.bb
index 34b710e88..7c3810154 100644
--- a/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_5.2.1.bb
+++ b/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_5.2.1.bb
@@ -28,7 +28,7 @@ do_install() {
28 rm -rf ${D}${datadir}/${BPN}/patches 28 rm -rf ${D}${datadir}/${BPN}/patches
29 29
30 install -d ${D}${sysconfdir}/apache2/conf.d 30 install -d ${D}${sysconfdir}/apache2/conf.d
31 install -m 0644 ${WORKDIR}/apache.conf ${D}${sysconfdir}/apache2/conf.d/phpmyadmin.conf 31 install -m 0644 ${UNPACKDIR}/apache.conf ${D}${sysconfdir}/apache2/conf.d/phpmyadmin.conf
32 32
33 # Remove a few scripts that explicitly require bash (!) 33 # Remove a few scripts that explicitly require bash (!)
34 rm -f ${D}${datadir}/phpmyadmin/libraries/transformations/*.sh 34 rm -f ${D}${datadir}/phpmyadmin/libraries/transformations/*.sh
diff --git a/meta-webserver/recipes-webadmin/cockpit/cockpit_304.bb b/meta-webserver/recipes-webadmin/cockpit/cockpit_304.bb
index df7f47a11..6a5eb4e66 100644
--- a/meta-webserver/recipes-webadmin/cockpit/cockpit_304.bb
+++ b/meta-webserver/recipes-webadmin/cockpit/cockpit_304.bb
@@ -193,7 +193,7 @@ do_install:append() {
193 chmod 4750 ${D}${libexecdir}/cockpit-session 193 chmod 4750 ${D}${libexecdir}/cockpit-session
194 194
195 install -d "${D}${sysconfdir}/pam.d" 195 install -d "${D}${sysconfdir}/pam.d"
196 install -p -m 0644 ${WORKDIR}/cockpit.pam ${D}${sysconfdir}/pam.d/cockpit 196 install -p -m 0644 ${UNPACKDIR}/cockpit.pam ${D}${sysconfdir}/pam.d/cockpit
197 197
198 # provided by firewalld 198 # provided by firewalld
199 rm -rf ${D}${libdir}/firewalld 199 rm -rf ${D}${libdir}/firewalld
diff --git a/meta-webserver/recipes-webadmin/netdata/netdata_1.44.3.bb b/meta-webserver/recipes-webadmin/netdata/netdata_1.44.3.bb
index 700c6b234..b06a5df31 100644
--- a/meta-webserver/recipes-webadmin/netdata/netdata_1.44.3.bb
+++ b/meta-webserver/recipes-webadmin/netdata/netdata_1.44.3.bb
@@ -55,13 +55,13 @@ do_install:append() {
55 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then 55 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
56 # Install systemd unit files 56 # Install systemd unit files
57 install -d ${D}${systemd_unitdir}/system 57 install -d ${D}${systemd_unitdir}/system
58 install -m 0644 ${WORKDIR}/netdata.service ${D}${systemd_unitdir}/system 58 install -m 0644 ${UNPACKDIR}/netdata.service ${D}${systemd_unitdir}/system
59 sed -i -e 's,@@datadir,${datadir_native},g' ${D}${systemd_unitdir}/system/netdata.service 59 sed -i -e 's,@@datadir,${datadir_native},g' ${D}${systemd_unitdir}/system/netdata.service
60 fi 60 fi
61 61
62 # Install default netdata.conf 62 # Install default netdata.conf
63 install -d ${D}${sysconfdir}/netdata 63 install -d ${D}${sysconfdir}/netdata
64 install -m 0644 ${WORKDIR}/netdata.conf ${D}${sysconfdir}/netdata/ 64 install -m 0644 ${UNPACKDIR}/netdata.conf ${D}${sysconfdir}/netdata/
65 sed -i -e 's,@@sysconfdir,${sysconfdir},g' ${D}${sysconfdir}/netdata/netdata.conf 65 sed -i -e 's,@@sysconfdir,${sysconfdir},g' ${D}${sysconfdir}/netdata/netdata.conf
66 sed -i -e 's,@@libdir,${libexecdir},g' ${D}${sysconfdir}/netdata/netdata.conf 66 sed -i -e 's,@@libdir,${libexecdir},g' ${D}${sysconfdir}/netdata/netdata.conf
67 sed -i -e 's,@@datadir,${datadir},g' ${D}${sysconfdir}/netdata/netdata.conf 67 sed -i -e 's,@@datadir,${datadir},g' ${D}${sysconfdir}/netdata/netdata.conf
diff --git a/meta-webserver/recipes-webadmin/webmin/webmin_1.850.bb b/meta-webserver/recipes-webadmin/webmin/webmin_1.850.bb
index 35ec09dae..bbc59443c 100644
--- a/meta-webserver/recipes-webadmin/webmin/webmin_1.850.bb
+++ b/meta-webserver/recipes-webadmin/webmin/webmin_1.850.bb
@@ -82,7 +82,7 @@ do_install() {
82 install -m 0755 webmin-init ${D}${sysconfdir}/init.d/webmin 82 install -m 0755 webmin-init ${D}${sysconfdir}/init.d/webmin
83 83
84 install -d ${D}${systemd_unitdir}/system 84 install -d ${D}${systemd_unitdir}/system
85 install -m 0644 ${WORKDIR}/webmin.service ${D}${systemd_unitdir}/system 85 install -m 0644 ${UNPACKDIR}/webmin.service ${D}${systemd_unitdir}/system
86 sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' \ 86 sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' \
87 ${D}${systemd_unitdir}/system/webmin.service 87 ${D}${systemd_unitdir}/system/webmin.service
88 88
@@ -117,7 +117,7 @@ do_install() {
117 export atboot=1 117 export atboot=1
118 export no_pam=1 118 export no_pam=1
119 mkdir -p $tempdir 119 mkdir -p $tempdir
120 ${S}/../setup.sh 120 ${UNPACKDIR}/setup.sh
121 121
122 # Ensure correct PERLLIB path 122 # Ensure correct PERLLIB path
123 sed -i -e 's#${D}##g' ${D}${sysconfdir}/webmin/start 123 sed -i -e 's#${D}##g' ${D}${sysconfdir}/webmin/start