summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.7.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.7.9.bb')
-rw-r--r--meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.7.9.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.7.9.bb b/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.7.9.bb
new file mode 100644
index 000000000..27dfe0b07
--- /dev/null
+++ b/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.7.9.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Web-based MySQL administration interface"
2HOMEPAGE = "http://www.phpmyadmin.net"
3# Main code is GPLv2, vendor/tecnickcom/tcpdf is under LGPLv3, js/jquery is under MIT
4LICENSE = "GPLv2 & LGPLv3 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://vendor/tecnickcom/tcpdf/LICENSE.TXT;md5=5c87b66a5358ebcc495b03e0afcd342c \
7 file://js/jquery/MIT-LICENSE.txt;md5=e43aa437a6a1ba421653bd5034333bf9 \
8"
9
10SRC_URI = "https://files.phpmyadmin.net/phpMyAdmin/${PV}/phpMyAdmin-${PV}-all-languages.tar.xz \
11 file://apache.conf \
12"
13
14SRC_URI[md5sum] = "0a862e3fa52c8b9078e0441ee82be831"
15SRC_URI[sha256sum] = "f19b503f0afb0dd3389d4bb11dab3f438d36e85eef11a5c400c592fd5f539398"
16
17S = "${WORKDIR}/phpMyAdmin-${PV}-all-languages"
18
19inherit allarch
20
21do_install() {
22 install -d ${D}${datadir}/${BPN}
23 cp -R --no-dereference --preserve=mode,links -v * ${D}${datadir}/${BPN}
24 chown -R root:root ${D}${datadir}/${BPN}
25 # Don't install patches to target
26 rm -rf ${D}${datadir}/${BPN}/patches
27
28 install -d ${D}${sysconfdir}/apache2/conf.d
29 install -m 0644 ${WORKDIR}/apache.conf ${D}${sysconfdir}/apache2/conf.d/phpmyadmin.conf
30
31 # Remove a few scripts that explicitly require bash (!)
32 rm -f ${D}${datadir}/phpmyadmin/libraries/transformations/*.sh
33}
34
35FILES_${PN} = "${datadir}/${BPN} \
36 ${sysconfdir}/apache2/conf.d"
37
38RDEPENDS_${PN} += "bash"