summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.4.4.bb')
-rw-r--r--meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.4.4.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.4.4.bb b/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.4.4.bb
new file mode 100644
index 000000000..c021c92f3
--- /dev/null
+++ b/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.4.4.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Web-based MySQL administration interface"
2HOMEPAGE = "http://www.phpmyadmin.net"
3# Main code is GPLv2, libraries/tcpdf is under LGPLv3, js/jquery is under MIT
4LICENSE = "GPLv2 & LGPLv3 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=eb723b61539feef013de476e68b5c50a \
6 file://libraries/tcpdf/LICENSE.TXT;md5=5c87b66a5358ebcc495b03e0afcd342c"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/phpmyadmin/phpMyAdmin/${PV}/phpMyAdmin-${PV}-all-languages.tar.xz \
9 file://apache.conf"
10
11SRC_URI[md5sum] = "912eeb8634bf99a7538a6fb4cad9135c"
12SRC_URI[sha256sum] = "bad1583fa3ef9534bc412822f873635c4b7f90488f17567d7ab0e2ea9bbd338c"
13
14S = "${WORKDIR}/phpMyAdmin-${PV}-all-languages"
15
16inherit allarch
17
18do_install() {
19 install -d ${D}${datadir}/${BPN}
20 cp -a * ${D}${datadir}/${BPN}
21 # Don't install patches to target
22 rm -rf ${D}${datadir}/${BPN}/patches
23
24 install -d ${D}${sysconfdir}/apache2/conf.d
25 install -m 0644 ${WORKDIR}/apache.conf ${D}${sysconfdir}/apache2/conf.d/phpmyadmin.conf
26
27 # Remove a few scripts that explicitly require bash (!)
28 rm -f ${D}${datadir}/phpmyadmin/libraries/transformations/*.sh
29}
30
31FILES_${PN} = "${datadir}/${BPN} \
32 ${sysconfdir}/apache2/conf.d"
33
34RDEPENDS_${PN} += "bash"