summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-configargparse.inc22
-rw-r--r--meta-python/recipes-devtools/python/python-configargparse_0.15.1.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-configargparse_0.15.1.bb3
3 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-configargparse.inc b/meta-python/recipes-devtools/python/python-configargparse.inc
new file mode 100644
index 000000000..17d296ff8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-configargparse.inc
@@ -0,0 +1,22 @@
1SUMMARY = "A drop-in replacement for argparse that allows options to also be set via config files and/or environment variables."
2HOMEPAGE = "https://github.com/bw2/ConfigArgParse"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=da746463714cc35999ed9a42339f2943"
5
6SRC_URI[md5sum] = "aba15b7973b7a70bea86fd69289f8fe3"
7SRC_URI[sha256sum] = "baaf0fd2c1c108d007f402dab5481ac5f12d77d034825bf5a27f8224757bd0ac"
8
9PYPI_PACKAGE = "ConfigArgParse"
10
11inherit pypi
12
13PACKAGECONFIG ?= "yaml"
14PACKAGECONFIG[yaml] = ",,,${PYTHON_PN}-pyyaml"
15
16RDEPENDS_${PN} += "\
17 ${PYTHON_PN}-core \
18 ${PYTHON_PN}-shell \
19"
20
21BBCLASSEXTEND = "native nativesdk"
22
diff --git a/meta-python/recipes-devtools/python/python-configargparse_0.15.1.bb b/meta-python/recipes-devtools/python/python-configargparse_0.15.1.bb
new file mode 100644
index 000000000..6d64b8d0b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-configargparse_0.15.1.bb
@@ -0,0 +1,3 @@
1inherit setuptools
2require python-configargparse.inc
3
diff --git a/meta-python/recipes-devtools/python/python3-configargparse_0.15.1.bb b/meta-python/recipes-devtools/python/python3-configargparse_0.15.1.bb
new file mode 100644
index 000000000..698eccf66
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-configargparse_0.15.1.bb
@@ -0,0 +1,3 @@
1inherit setuptools3
2require python-configargparse.inc
3