summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pylint_1.6.4.bb19
1 files changed, 18 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-pylint_1.6.4.bb b/meta-python/recipes-devtools/python/python-pylint_1.6.4.bb
index b9219dd28..2e3445100 100644
--- a/meta-python/recipes-devtools/python/python-pylint_1.6.4.bb
+++ b/meta-python/recipes-devtools/python/python-pylint_1.6.4.bb
@@ -22,6 +22,23 @@ RDEPENDS_${PN} += "python-codecs \
22 python-stringold \ 22 python-stringold \
23 python-subprocess \ 23 python-subprocess \
24 python-textutils \ 24 python-textutils \
25 python-unittest" 25 python-unittest \
26 python-backports-functools-lru-cache \
27 python-setuptools \
28 python-astroid \
29 python-wrapt \
30 python-isort \
31 python-lazy-object-proxy \
32 "
26 33
27inherit pypi setuptools 34inherit pypi setuptools
35
36do_install_append(){
37 rm ${D}${bindir}/pylint
38 cat >> ${D}${bindir}/pylint <<EOF
39#!/usr/bin/env python
40from pylint import run_pylint
41run_pylint()
42EOF
43 chmod 755 ${D}${bindir}/pylint
44}