summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-toml.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-toml_0.10.0.bb6
-rw-r--r--meta-python/recipes-devtools/python/python3-toml_0.10.0.bb6
3 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-toml.inc b/meta-python/recipes-devtools/python/python-toml.inc
new file mode 100644
index 000000000..a3b3dfc86
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-toml.inc
@@ -0,0 +1,10 @@
1SUMMARY = "Python Library for Tom's Obvious, Minimal Language"
2HOMEPAGE = "https://github.com/uiri/toml"
3LICENSE = "MIT"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=6d6012eea477117abf51c31262a152f8"
6
7SRC_URI[md5sum] = "63fffbe2d632865ec29cd69bfdf36682"
8SRC_URI[sha256sum] = "229f81c57791a41d65e399fc06bf0848bab550a9dfd5ed66df18ce5f05e73d5c"
9
10inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-toml_0.10.0.bb b/meta-python/recipes-devtools/python/python-toml_0.10.0.bb
new file mode 100644
index 000000000..3c4acce67
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-toml_0.10.0.bb
@@ -0,0 +1,6 @@
1inherit setuptools
2require python-toml.inc
3
4RDEPENDS_${PN} += " \
5 ${PYTHON_PN}-datetime \
6"
diff --git a/meta-python/recipes-devtools/python/python3-toml_0.10.0.bb b/meta-python/recipes-devtools/python/python3-toml_0.10.0.bb
new file mode 100644
index 000000000..cebb41a53
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-toml_0.10.0.bb
@@ -0,0 +1,6 @@
1inherit setuptools3
2require python-toml.inc
3
4RDEPENDS_${PN} += " \
5 ${PYTHON_PN}-misc \
6"