diff options
Diffstat (limited to 'meta-python')
3 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pika.inc b/meta-python/recipes-devtools/python/python-pika.inc new file mode 100644 index 000000000..10be5bb62 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pika.inc | |||
@@ -0,0 +1,22 @@ | |||
1 | SUMMARY = "Pika is a RabbitMQ (AMQP 0-9-1) client library for Python." | ||
2 | DESCRIPTION = " \ | ||
3 | Pika is a pure-Python implementation of the AMQP 0-9-1 protocol \ | ||
4 | including RabbitMQ’s extensions. \ | ||
5 | " | ||
6 | SECTION = "devel/python" | ||
7 | HOMEPAGE = "https://pika.readthedocs.io" | ||
8 | LICENSE = "BSD" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=535836bf0a5de515a7bfee026075701d" | ||
10 | |||
11 | SRC_URI[md5sum] = "6002400cdd33bf85ec8680ece72910d4" | ||
12 | SRC_URI[sha256sum] = "9fa76ba4b65034b878b2b8de90ff8660a59d925b087c5bb88f8fdbb4b64a1dbf" | ||
13 | |||
14 | inherit pypi | ||
15 | |||
16 | PYPI_PACKAGE = "pika" | ||
17 | |||
18 | RDEPENDS_${PN} += " \ | ||
19 | ${PYTHON_PN}-logging \ | ||
20 | ${PYTHON_PN}-tornado \ | ||
21 | ${PYTHON_PN}-twisted \ | ||
22 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-pika_1.1.0.bb b/meta-python/recipes-devtools/python/python-pika_1.1.0.bb new file mode 100644 index 000000000..f7e019867 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pika_1.1.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools | ||
2 | require python-pika.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-pika_1.1.0.bb b/meta-python/recipes-devtools/python/python3-pika_1.1.0.bb new file mode 100644 index 000000000..a1515881f --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pika_1.1.0.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-pika.inc | ||