summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyopenssl.inc18
-rw-r--r--meta-python/recipes-devtools/python/python-pyopenssl_16.0.0.bb17
-rw-r--r--meta-python/recipes-devtools/python/python3-pyopenssl_16.0.0.bb2
3 files changed, 21 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyopenssl.inc b/meta-python/recipes-devtools/python/python-pyopenssl.inc
new file mode 100644
index 000000000..88b430606
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyopenssl.inc
@@ -0,0 +1,18 @@
1SUMMARY = "Simple Python wrapper around the OpenSSL library"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
4
5DEPENDS = "openssl ${PYTHON_PN}-cryptography"
6
7SRC_URI[md5sum] = "9587d813dcf656e9f2760e41a3682dc3"
8SRC_URI[sha256sum] = "363d10ee43d062285facf4e465f4f5163f9f702f9134f0a5896f134cbb92d17d"
9
10PYPI_PACKAGE = "pyOpenSSL"
11
12PACKAGES =+ "${PN}-tests"
13FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
14
15RDEPENDS_${PN} = "python-threading python-six python-cryptography"
16RDEPENDS_${PN}-tests = "${PN}"
17
18BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pyopenssl_16.0.0.bb b/meta-python/recipes-devtools/python/python-pyopenssl_16.0.0.bb
index 81738588b..d7177e2d1 100644
--- a/meta-python/recipes-devtools/python/python-pyopenssl_16.0.0.bb
+++ b/meta-python/recipes-devtools/python/python-pyopenssl_16.0.0.bb
@@ -1,17 +1,2 @@
1SUMMARY = "Simple Python wrapper around the OpenSSL library"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
4
5DEPENDS = "openssl python-cryptography"
6
7SRC_URI[md5sum] = "9587d813dcf656e9f2760e41a3682dc3"
8SRC_URI[sha256sum] = "363d10ee43d062285facf4e465f4f5163f9f702f9134f0a5896f134cbb92d17d"
9
10PYPI_PACKAGE = "pyOpenSSL"
11inherit pypi setuptools 1inherit pypi setuptools
12 2require python-pyopenssl.inc
13PACKAGES =+ "${PN}-tests"
14FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
15
16RDEPENDS_${PN} = "python-threading python-six python-cryptography"
17RDEPENDS_${PN}-tests = "${PN}"
diff --git a/meta-python/recipes-devtools/python/python3-pyopenssl_16.0.0.bb b/meta-python/recipes-devtools/python/python3-pyopenssl_16.0.0.bb
new file mode 100644
index 000000000..0f0f83e3a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyopenssl_16.0.0.bb
@@ -0,0 +1,2 @@
1inherit pypi setuptools3
2require python-pyopenssl.inc