summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyperclip.inc14
-rw-r--r--meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb16
2 files changed, 14 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyperclip.inc b/meta-python/recipes-devtools/python/python-pyperclip.inc
deleted file mode 100644
index 85a4312c25..0000000000
--- a/meta-python/recipes-devtools/python/python-pyperclip.inc
+++ /dev/null
@@ -1,14 +0,0 @@
1DESCRIPTION = "A cross-platform clipboard module for Python. (only handles plain text for now)"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://PKG-INFO;md5=a428356ada7737b416ec4b63dc65d581"
4
5SRC_URI[md5sum] = "6bbb8598579cc3ee50554b4c59d0cfae"
6SRC_URI[sha256sum] = "979325468ccf682104d5dcaf753f869868100631301d3e72f47babdea5700d1c"
7
8inherit pypi
9
10RDEPENDS_${PN} += " \
11 ${PYTHON_PN}-ctypes \
12"
13
14BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb b/meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb
index ee6f88bbbc..52d109abc8 100644
--- a/meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pyperclip_1.7.0.bb
@@ -1,2 +1,14 @@
1inherit setuptools3 1DESCRIPTION = "A cross-platform clipboard module for Python. (only handles plain text for now)"
2require python-pyperclip.inc 2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://PKG-INFO;md5=a428356ada7737b416ec4b63dc65d581"
4
5SRC_URI[md5sum] = "6bbb8598579cc3ee50554b4c59d0cfae"
6SRC_URI[sha256sum] = "979325468ccf682104d5dcaf753f869868100631301d3e72f47babdea5700d1c"
7
8inherit pypi setuptools3
9
10RDEPENDS_${PN} += " \
11 ${PYTHON_PN}-ctypes \
12"
13
14BBCLASSEXTEND = "native nativesdk"