summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-mako.inc21
-rw-r--r--meta-python/recipes-devtools/python/python-mako_1.0.7.bb2
2 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-mako.inc b/meta-python/recipes-devtools/python/python-mako.inc
new file mode 100644
index 000000000..a9fa55639
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-mako.inc
@@ -0,0 +1,21 @@
1SUMMARY = "A super-fast templating language that borrows the best ideas from the existing templating languages"
2HOMEPAGE = "http://www.makotemplates.org/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1bb21fa2d2f7a534c884b990430a6863"
6
7PYPI_PACKAGE = "Mako"
8
9inherit pypi
10
11SRC_URI[md5sum] = "5836cc997b1b773ef389bf6629c30e65"
12SRC_URI[sha256sum] = "4e02fde57bd4abb5ec400181e4c314f56ac3e49ba4fb8b0d50bba18cb27d25ae"
13
14RDEPENDS_${PN} = " \
15 ${PYTHON_PN}-html \
16 ${PYTHON_PN}-netclient \
17 ${PYTHON_PN}-shell \
18 ${PYTHON_PN}-threading \
19"
20
21BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-mako_1.0.7.bb b/meta-python/recipes-devtools/python/python-mako_1.0.7.bb
new file mode 100644
index 000000000..3372eeb28
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-mako_1.0.7.bb
@@ -0,0 +1,2 @@
1inherit setuptools
2require python-mako.inc