summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography.inc48
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography_1.4.bb53
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography_1.4.bb10
4 files changed, 70 insertions, 43 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography.inc b/meta-python/recipes-devtools/python/python-cryptography.inc
new file mode 100644
index 000000000..d4767b1d9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cryptography.inc
@@ -0,0 +1,48 @@
1SUMMARY = "Provides cryptographic recipes and primitives to python developers"
2LICENSE = "Apache-2.0 | BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
4
5DEPENDS += " \
6 ${PYTHON_PN}-cffi \
7 ${PYTHON_PN}-cffi-native \
8 ${PYTHON_PN}-pyasn1 \
9 ${PYTHON_PN}-six \
10"
11
12SRC_URI[md5sum] = "a9763e3831cc7cdb402c028fac1ceb39"
13SRC_URI[sha256sum] = "bb149540ed90c4b2171bf694fe6991d6331bc149ae623c8ff419324f4222d128"
14
15RDEPENDS_${PN} += " \
16 ${PYTHON_PN}-cffi \
17 ${PYTHON_PN}-idna \
18 ${PYTHON_PN}-numbers \
19 ${PYTHON_PN}-pyasn1 \
20 ${PYTHON_PN}-pycparser \
21 ${PYTHON_PN}-setuptools \
22 ${PYTHON_PN}-six \
23 ${PYTHON_PN}-subprocess \
24 ${PYTHON_PN}-threading \
25"
26
27RDEPENDS_${PN}-ptest += " \
28 ${PN} \
29 ${PYTHON_PN}-cryptography-vectors \
30 ${PYTHON_PN}-iso8601 \
31 ${PYTHON_PN}-pretend \
32 ${PYTHON_PN}-pytest \
33"
34
35inherit ptest
36
37do_install_ptest() {
38 install -d ${D}${PTEST_PATH}/tests
39 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
40 install -d ${D}${PTEST_PATH}/tests/hazmat
41 cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
42}
43
44FILES_${PN}-dbg += " \
45 ${libdir}/${PYTHON_PN}2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
46"
47
48BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-cryptography_1.4.bb b/meta-python/recipes-devtools/python/python-cryptography_1.4.bb
index a6b5bd088..b05c61510 100644
--- a/meta-python/recipes-devtools/python/python-cryptography_1.4.bb
+++ b/meta-python/recipes-devtools/python/python-cryptography_1.4.bb
@@ -1,49 +1,16 @@
1SUMMARY = "Provides cryptographic recipes and primitives to Python developers"
2LICENSE = "Apache-2.0 | BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
4DEPENDS += " python-cffi-native python-cffi python-enum34 python-six python-pyasn1"
5SRCNAME = "cryptography"
6
7SRC_URI = "file://run-ptest"
8
9SRC_URI[md5sum] = "a9763e3831cc7cdb402c028fac1ceb39"
10SRC_URI[sha256sum] = "bb149540ed90c4b2171bf694fe6991d6331bc149ae623c8ff419324f4222d128"
11
12inherit pypi setuptools 1inherit pypi setuptools
2require python-cryptography.inc
13 3
14RDEPENDS_${PN} = "\ 4SRC_URI += " \
15 python-pyasn1\ 5 file://run-ptest \
16 python-six\
17 python-cffi\
18 python-enum34\
19 python-setuptools\
20 python-pycparser\
21 python-subprocess\
22 python-threading\
23 python-numbers\
24 python-contextlib\
25 python-ipaddress\
26 python-pyasn1\
27 python-idna\
28" 6"
29 7
30RDEPENDS_${PN}-ptest = "\ 8DEPENDS += " \
31 ${PN}\ 9 ${PYTHON_PN}-enum34 \
32 python-pytest\
33 python-pretend\
34 python-iso8601\
35 python-cryptography-vectors\
36" 10"
37 11
38inherit ptest 12RDEPENDS_${PN} += " \
39 13 ${PYTHON_PN}-contextlib \
40do_install_ptest() { 14 ${PYTHON_PN}-enum34 \
41 install -d ${D}${PTEST_PATH}/tests 15 ${PYTHON_PN}-ipaddress \
42 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ 16"
43 install -d ${D}${PTEST_PATH}/tests/hazmat
44 cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
45}
46
47FILES_${PN}-dbg += " \
48 ${libdir}/python2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
49 "
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/run-ptest b/meta-python/recipes-devtools/python/python3-cryptography/run-ptest
new file mode 100644
index 000000000..0ba239c2a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cryptography/run-ptest
@@ -0,0 +1,2 @@
1#!/bin/sh
2py.test
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_1.4.bb b/meta-python/recipes-devtools/python/python3-cryptography_1.4.bb
new file mode 100644
index 000000000..f807042ec
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cryptography_1.4.bb
@@ -0,0 +1,10 @@
1inherit pypi setuptools3
2require python-cryptography.inc
3
4SRC_URI += " \
5 file://run-ptest \
6"
7
8RDEPENDS_${PN} += " \
9 ${PYTHON_PN}-lang \
10"