summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-devtools/python/python3-google-auth-oauthlib/run-ptest4
-rw-r--r--meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb25
3 files changed, 26 insertions, 4 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index d3096039b..0cb3046cf 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -19,6 +19,7 @@ PTESTS_FAST_META_PYTHON = "\
19 python3-execnet \ 19 python3-execnet \
20 python3-freezegun \ 20 python3-freezegun \
21 python3-geojson \ 21 python3-geojson \
22 python3-google-auth-oauthlib \
22 python3-gpiod \ 23 python3-gpiod \
23 python3-gunicorn \ 24 python3-gunicorn \
24 python3-html2text \ 25 python3-html2text \
diff --git a/meta-python/recipes-devtools/python/python3-google-auth-oauthlib/run-ptest b/meta-python/recipes-devtools/python/python3-google-auth-oauthlib/run-ptest
new file mode 100644
index 000000000..f1c8729f0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-auth-oauthlib/run-ptest
@@ -0,0 +1,4 @@
1#!/bin/sh
2
3pytest --automake
4
diff --git a/meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb b/meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb
index 5c071ac41..70e843a09 100644
--- a/meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb
@@ -6,9 +6,26 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6 6
7SRC_URI[sha256sum] = "292d2d3783349f2b0734a0a0207b1e1e322ac193c2c09d8f7c613fb7cc501ea8" 7SRC_URI[sha256sum] = "292d2d3783349f2b0734a0a0207b1e1e322ac193c2c09d8f7c613fb7cc501ea8"
8 8
9inherit pypi setuptools3 9inherit pypi setuptools3 ptest
10 10
11RDEPENDS:${PN} = " \ 11SRC_URI += " \
12 python3-google-auth \ 12 file://run-ptest \
13 python3-requests-oauthlib \ 13"
14
15RDEPENDS:${PN}-ptest += " \
16 python3-click \
17 python3-mock \
18 python3-pytest \
19 python3-unittest-automake-output \
20 python3-unixadmin \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
27
28RDEPENDS:${PN} += " \
29 python3-google-auth \
30 python3-requests-oauthlib \
14" 31"