summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pytest-helpers-namespace.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-pytest-helpers-namespace_2016.7.10.bb11
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-helpers-namespace_2016.7.10.bb7
3 files changed, 19 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest-helpers-namespace.inc b/meta-python/recipes-devtools/python/python-pytest-helpers-namespace.inc
new file mode 100644
index 000000000..a69867d91
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pytest-helpers-namespace.inc
@@ -0,0 +1,10 @@
1DESCRIPTION = "This plugin does not provide any helpers to pytest, it does, however, provide a helpers namespace in pytest which enables you to register helper functions in your conftest.py to be used within your tests without having to import them."
2HOMEPAGE = "https://github.com/saltstack/pytest-helpers-namespace"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=71fac4dfeee99c39c51f617e9486237c"
6
7SRC_URI[md5sum] = "80fe3e515f640b1459709b539f6b857e"
8SRC_URI[sha256sum] = "d8bdb017c0f7271699c08850b6b12e1ce9e52913cbd4461b5febd21082a29113"
9
10inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-pytest-helpers-namespace_2016.7.10.bb b/meta-python/recipes-devtools/python/python-pytest-helpers-namespace_2016.7.10.bb
index afca48702..2b6ee8550 100644
--- a/meta-python/recipes-devtools/python/python-pytest-helpers-namespace_2016.7.10.bb
+++ b/meta-python/recipes-devtools/python/python-pytest-helpers-namespace_2016.7.10.bb
@@ -1,13 +1,6 @@
1DESCRIPTION = "This plugin does not provide any helpers to pytest, it does, however, provide a helpers namespace in pytest which enables you to register helper functions in your conftest.py to be used within your tests without having to import them." 1require python-pytest-helpers-namespace.inc
2HOMEPAGE = "https://github.com/saltstack/pytest-helpers-namespace"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=71fac4dfeee99c39c51f617e9486237c"
6 2
7SRC_URI[md5sum] = "80fe3e515f640b1459709b539f6b857e" 3inherit setuptools
8SRC_URI[sha256sum] = "d8bdb017c0f7271699c08850b6b12e1ce9e52913cbd4461b5febd21082a29113"
9
10inherit pypi setuptools
11 4
12RDEPENDS_${PN} += " \ 5RDEPENDS_${PN} += " \
13 python-pytest \ 6 python-pytest \
diff --git a/meta-python/recipes-devtools/python/python3-pytest-helpers-namespace_2016.7.10.bb b/meta-python/recipes-devtools/python/python3-pytest-helpers-namespace_2016.7.10.bb
new file mode 100644
index 000000000..f03f5d415
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-helpers-namespace_2016.7.10.bb
@@ -0,0 +1,7 @@
1require python-pytest-helpers-namespace.inc
2
3inherit setuptools3
4
5RDEPENDS_${PN} += " \
6 python3-pytest \
7 "