diff options
Diffstat (limited to 'meta-python/recipes-extended')
9 files changed, 16 insertions, 16 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb index 2b5b253b5d..204793759d 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb +++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb | |||
@@ -30,17 +30,17 @@ REQUIRED_DISTRO_FEATURES = "systemd" | |||
30 | 30 | ||
31 | inherit setuptools3 python3native | 31 | inherit setuptools3 python3native |
32 | 32 | ||
33 | RDEPENDS_${PN} += "python3-pykickstart python3-pyudev \ | 33 | RDEPENDS:${PN} += "python3-pykickstart python3-pyudev \ |
34 | parted python3-pyparted multipath-tools \ | 34 | parted python3-pyparted multipath-tools \ |
35 | lsof cryptsetup libblockdev \ | 35 | lsof cryptsetup libblockdev \ |
36 | libbytesize \ | 36 | libbytesize \ |
37 | " | 37 | " |
38 | 38 | ||
39 | FILES_${PN} += " \ | 39 | FILES:${PN} += " \ |
40 | ${datadir}/dbus-1/system-services \ | 40 | ${datadir}/dbus-1/system-services \ |
41 | " | 41 | " |
42 | 42 | ||
43 | inherit systemd | 43 | inherit systemd |
44 | 44 | ||
45 | SYSTEMD_AUTO_ENABLE = "disable" | 45 | SYSTEMD_AUTO_ENABLE = "disable" |
46 | SYSTEMD_SERVICE_${PN} = "blivet.service" | 46 | SYSTEMD_SERVICE:${PN} = "blivet.service" |
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb index 92402bee56..4f5856d1b2 100644 --- a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb +++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb | |||
@@ -18,11 +18,11 @@ REQUIRED_DISTRO_FEATURES = "x11 systemd" | |||
18 | 18 | ||
19 | inherit setuptools3 python3native | 19 | inherit setuptools3 python3native |
20 | 20 | ||
21 | RDEPENDS_${PN} = "python3-pygobject python3 \ | 21 | RDEPENDS:${PN} = "python3-pygobject python3 \ |
22 | python3-blivet gtk+3 \ | 22 | python3-blivet gtk+3 \ |
23 | python3-pid libreport \ | 23 | python3-pid libreport \ |
24 | " | 24 | " |
25 | 25 | ||
26 | FILES_${PN} += " \ | 26 | FILES:${PN} += " \ |
27 | ${datadir}/* \ | 27 | ${datadir}/* \ |
28 | " | 28 | " |
diff --git a/meta-python/recipes-extended/python-cson/python3-cson_git.bb b/meta-python/recipes-extended/python-cson/python3-cson_git.bb index 5c74c7a307..7bc61f06d7 100644 --- a/meta-python/recipes-extended/python-cson/python3-cson_git.bb +++ b/meta-python/recipes-extended/python-cson/python3-cson_git.bb | |||
@@ -12,8 +12,8 @@ SRC_URI = "git://github.com/gt3389b/python-cson.git" | |||
12 | 12 | ||
13 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
14 | 14 | ||
15 | RDEPENDS_${PN}_class-native = "" | 15 | RDEPENDS:${PN}:class-native = "" |
16 | DEPENDS_append_class-native = " python-native " | 16 | DEPENDS:append:class-native = " python-native " |
17 | 17 | ||
18 | inherit setuptools3 | 18 | inherit setuptools3 |
19 | 19 | ||
diff --git a/meta-python/recipes-extended/python-meh/python3-meh_0.50.bb b/meta-python/recipes-extended/python-meh/python3-meh_0.50.bb index 64a24ade3e..372b3a006f 100644 --- a/meta-python/recipes-extended/python-meh/python3-meh_0.50.bb +++ b/meta-python/recipes-extended/python-meh/python3-meh_0.50.bb | |||
@@ -13,5 +13,5 @@ SRC_URI = "git://github.com/rhinstaller/python-meh.git;protocol=https;branch=mas | |||
13 | " | 13 | " |
14 | SRCREV = "11980776c5ad757401ea1d12fd1f331d96428105" | 14 | SRCREV = "11980776c5ad757401ea1d12fd1f331d96428105" |
15 | 15 | ||
16 | FILES_${PN} += "${datadir}/*" | 16 | FILES:${PN} += "${datadir}/*" |
17 | 17 | ||
diff --git a/meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.1.bb b/meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.1.bb index 5949a55fa8..7cf88ec332 100644 --- a/meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.1.bb +++ b/meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.1.bb | |||
@@ -10,7 +10,7 @@ PYPI_PACKAGE = "ephem" | |||
10 | 10 | ||
11 | inherit pypi setuptools3 | 11 | inherit pypi setuptools3 |
12 | 12 | ||
13 | RDEPENDS_${PN} += "\ | 13 | RDEPENDS:${PN} += "\ |
14 | ${PYTHON_PN}-datetime \ | 14 | ${PYTHON_PN}-datetime \ |
15 | ${PYTHON_PN}-math \ | 15 | ${PYTHON_PN}-math \ |
16 | " | 16 | " |
diff --git a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.32.bb b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.32.bb index 62d2729dc8..829ada4f8b 100644 --- a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.32.bb +++ b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.32.bb | |||
@@ -3,10 +3,10 @@ HOMEPAGE = "http://fedoraproject.org/wiki/pykickstart" | |||
3 | LICENSE = "GPLv2+" | 3 | LICENSE = "GPLv2+" |
4 | 4 | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" |
6 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" | 6 | FILESEXTRAPATHS:prepend := "${THISDIR}/files:" |
7 | 7 | ||
8 | DEPENDS = "python3" | 8 | DEPENDS = "python3" |
9 | RDEPENDS_${PN} = "python3 \ | 9 | RDEPENDS:${PN} = "python3 \ |
10 | python3-requests \ | 10 | python3-requests \ |
11 | python3-six \ | 11 | python3-six \ |
12 | " | 12 | " |
diff --git a/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.7.bb b/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.7.bb index 8909aa11f4..765201ca7b 100644 --- a/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.7.bb +++ b/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.7.bb | |||
@@ -16,10 +16,10 @@ inherit pypi distutils3 | |||
16 | 16 | ||
17 | DEPENDS += "parted" | 17 | DEPENDS += "parted" |
18 | 18 | ||
19 | RDEPENDS_${PN}_class-target += " \ | 19 | RDEPENDS:${PN}:class-target += " \ |
20 | parted (>= 2.3) \ | 20 | parted (>= 2.3) \ |
21 | python3-stringold python3-codecs python3-math \ | 21 | python3-stringold python3-codecs python3-math \ |
22 | " | 22 | " |
23 | RDEPENDS_${PN}_class-native = "" | 23 | RDEPENDS:${PN}:class-native = "" |
24 | 24 | ||
25 | BBCLASSEXTEND = "native" | 25 | BBCLASSEXTEND = "native" |
diff --git a/meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb b/meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb index 988dae1335..a6ca4d5f83 100644 --- a/meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb +++ b/meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb | |||
@@ -27,7 +27,7 @@ DEPENDS += " \ | |||
27 | ${PYTHON_PN}-wheel-native \ | 27 | ${PYTHON_PN}-wheel-native \ |
28 | " | 28 | " |
29 | 29 | ||
30 | RDEPENDS_${PN}_class-target += "\ | 30 | RDEPENDS:${PN}:class-target += "\ |
31 | ${PYTHON_PN}-datetime \ | 31 | ${PYTHON_PN}-datetime \ |
32 | ${PYTHON_PN}-io \ | 32 | ${PYTHON_PN}-io \ |
33 | ${PYTHON_PN}-netclient \ | 33 | ${PYTHON_PN}-netclient \ |
@@ -43,7 +43,7 @@ RDEPENDS_${PN}_class-target += "\ | |||
43 | ${PYTHON_PN}-yamlloader \ | 43 | ${PYTHON_PN}-yamlloader \ |
44 | " | 44 | " |
45 | 45 | ||
46 | ALTERNATIVE_${PN} = "mof_compiler" | 46 | ALTERNATIVE:${PN} = "mof_compiler" |
47 | ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler" | 47 | ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler" |
48 | 48 | ||
49 | ALTERNATIVE_PRIORITY = "60" | 49 | ALTERNATIVE_PRIORITY = "60" |
diff --git a/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.9.0.bb b/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.9.0.bb index b06fee5500..46b6a99605 100644 --- a/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.9.0.bb +++ b/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.9.0.bb | |||
@@ -15,7 +15,7 @@ DEPENDS += " \ | |||
15 | ${PYTHON_PN}-click-native \ | 15 | ${PYTHON_PN}-click-native \ |
16 | " | 16 | " |
17 | 17 | ||
18 | RDEPENDS_${PN}_class-target += "\ | 18 | RDEPENDS:${PN}:class-target += "\ |
19 | ${PYTHON_PN}-ply \ | 19 | ${PYTHON_PN}-ply \ |
20 | ${PYTHON_PN}-pyyaml \ | 20 | ${PYTHON_PN}-pyyaml \ |
21 | ${PYTHON_PN}-six \ | 21 | ${PYTHON_PN}-six \ |