summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch')
-rw-r--r--meta-python/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch b/meta-python/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch
new file mode 100644
index 000000000..db3ab9fc3
--- /dev/null
+++ b/meta-python/recipes-extended/python-pyparted/python-pyparted/0001-fix-version-float-check.patch
@@ -0,0 +1,26 @@
1check_mod_version breaks if module version is of x.y.z form
2use a regex to help cast x.y.z version to a float
3
4Upstream-Status: Pending
5
6Index: git/setup.py
7===================================================================
8--- git.orig/setup.py
9+++ git/setup.py
10@@ -25,6 +25,7 @@ import glob
11 import os
12 import platform
13 import sys
14+import re
15 from distutils.ccompiler import new_compiler
16 from distutils.errors import CompileError
17 from distutils.errors import LinkError
18@@ -51,6 +52,8 @@ def pkgconfig(*packages, **kwargs):
19
20 def check_mod_version(module, version):
21 modversion = subprocess.check_output(["pkg-config", "--modversion", module])
22+ match = re.search('([0-9]+\.[0-9]+)', modversion)
23+ modversion = match.group(0)
24 if not float(modversion) >= float(version):
25 sys.stderr.write("*** Minimum required %s version: %s, found: %s\n" % (module, version, modversion,))
26 sys.exit(1)