summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-smbus.inc7
1 files changed, 1 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python-smbus.inc b/meta-python/recipes-devtools/python/python-smbus.inc
index 0bca58f1f..f472a57f4 100644
--- a/meta-python/recipes-devtools/python/python-smbus.inc
+++ b/meta-python/recipes-devtools/python/python-smbus.inc
@@ -1,6 +1,7 @@
1SUMMARY = "Set of i2c tools for linux - Python module" 1SUMMARY = "Set of i2c tools for linux - Python module"
2LICENSE = "GPLv2" 2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://smbusmodule.c;beginline=1;endline=17;md5=fa24df321a520ff8e10f203425ab9fa8" 3LIC_FILES_CHKSUM = "file://smbusmodule.c;beginline=1;endline=17;md5=fa24df321a520ff8e10f203425ab9fa8"
4PR = "r1"
4 5
5SRC_URI = "${KERNELORG_MIRROR}/software/utils/i2c-tools/i2c-tools-${PV}.tar.gz " 6SRC_URI = "${KERNELORG_MIRROR}/software/utils/i2c-tools/i2c-tools-${PV}.tar.gz "
6SRC_URI[md5sum] = "d92a288d70f306d3895e3a7e9c14c9aa" 7SRC_URI[md5sum] = "d92a288d70f306d3895e3a7e9c14c9aa"
@@ -9,9 +10,3 @@ SRC_URI[sha256sum] = "5b60daf6f011de0acb61de57dba62f2054bb39f19961d67e0c91610f07
9DEPENDS += "i2c-tools" 10DEPENDS += "i2c-tools"
10 11
11S = "${WORKDIR}/i2c-tools-${PV}/py-smbus/" 12S = "${WORKDIR}/i2c-tools-${PV}/py-smbus/"
12
13do_configure_prepend() {
14 # Adjust for OE header rename
15 sed -i s:linux/i2c-dev.h:linux/i2c-dev-user.h: Module.mk
16 sed -i s:linux/i2c-dev.h:linux/i2c-dev-user.h: smbusmodule.c
17}