diff options
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-geojson/run-ptest | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-geojson_3.1.0.bb | 3 |
2 files changed, 3 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-geojson/run-ptest b/meta-python/recipes-devtools/python/python3-geojson/run-ptest index b63c4de0d..8d2017d39 100644 --- a/meta-python/recipes-devtools/python/python3-geojson/run-ptest +++ b/meta-python/recipes-devtools/python/python3-geojson/run-ptest | |||
@@ -1,3 +1,3 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | 3 | pytest --automake |
diff --git a/meta-python/recipes-devtools/python/python3-geojson_3.1.0.bb b/meta-python/recipes-devtools/python/python3-geojson_3.1.0.bb index 79ad228d1..742f921e5 100644 --- a/meta-python/recipes-devtools/python/python3-geojson_3.1.0.bb +++ b/meta-python/recipes-devtools/python/python3-geojson_3.1.0.bb | |||
@@ -12,7 +12,8 @@ SRC_URI += " \ | |||
12 | " | 12 | " |
13 | 13 | ||
14 | RDEPENDS:${PN}-ptest += " \ | 14 | RDEPENDS:${PN}-ptest += " \ |
15 | ${PYTHON_PN}-pytest \ | 15 | python3-pytest \ |
16 | python3-unittest-automake-output \ | ||
16 | " | 17 | " |
17 | 18 | ||
18 | do_install_ptest() { | 19 | do_install_ptest() { |