summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-wsproto/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-wsproto_1.2.0.bb27
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-wsproto/run-ptest b/meta-python/recipes-devtools/python/python3-wsproto/run-ptest
new file mode 100644
index 000000000..8d2017d39
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-wsproto/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-wsproto_1.2.0.bb b/meta-python/recipes-devtools/python/python3-wsproto_1.2.0.bb
new file mode 100644
index 000000000..09f5565a9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-wsproto_1.2.0.bb
@@ -0,0 +1,27 @@
1SUMMARY = "WebSockets state-machine based protocol implementation"
2HOMEPAGE = "https://github.com/python-hyper/wsproto/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=69fabf732409f4ac61875827b258caaf"
5
6inherit pypi setuptools3 ptest
7
8SRC_URI[sha256sum] = "ad565f26ecb92588a3e43bc3d96164de84cd9902482b130d0ddbaa9664a85065"
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15 python3-pytest \
16 python3-unittest-automake-output \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/test/* ${D}${PTEST_PATH}/tests/
22}
23
24RDEPENDS:${PN} += " \
25 python3-h11 \
26 python3-netclient \
27"