summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-pytest-tempdir.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb11
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-tempdir_2016.8.20.bb7
3 files changed, 19 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest-tempdir.inc b/meta-python/recipes-devtools/python/python-pytest-tempdir.inc
new file mode 100644
index 000000000..196f6d644
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pytest-tempdir.inc
@@ -0,0 +1,10 @@
1DESCRIPTION = "Adds support for a predictable and repeatable temporary directory."
2HOMEPAGE = "https://github.com/saltstack/pytest-tempdir"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=8751a9cf4a70be4f02697a9b89e686ce"
6
7SRC_URI[md5sum] = "f87f2583f5f8aaca7203d57ada3948b5"
8SRC_URI[sha256sum] = "65ff815966ea6dfc07ca1b43747c9888a6d883971170e67b16290f9f50d434ea"
9
10inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb b/meta-python/recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb
index 74030dcf5..8a9b83e3d 100644
--- a/meta-python/recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb
+++ b/meta-python/recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb
@@ -1,13 +1,6 @@
1DESCRIPTION = "Adds support for a predictable and repeatable temporary directory." 1require python-pytest-tempdir.inc
2HOMEPAGE = "https://github.com/saltstack/pytest-tempdir"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=8751a9cf4a70be4f02697a9b89e686ce"
6 2
7SRC_URI[md5sum] = "f87f2583f5f8aaca7203d57ada3948b5" 3inherit setuptools
8SRC_URI[sha256sum] = "65ff815966ea6dfc07ca1b43747c9888a6d883971170e67b16290f9f50d434ea"
9
10inherit pypi setuptools
11 4
12RDEPENDS_${PN} += " \ 5RDEPENDS_${PN} += " \
13 python-pytest \ 6 python-pytest \
diff --git a/meta-python/recipes-devtools/python/python3-pytest-tempdir_2016.8.20.bb b/meta-python/recipes-devtools/python/python3-pytest-tempdir_2016.8.20.bb
new file mode 100644
index 000000000..02e821563
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-tempdir_2016.8.20.bb
@@ -0,0 +1,7 @@
1require python-pytest-tempdir.inc
2
3inherit setuptools3
4
5RDEPENDS_${PN} += " \
6 python3-pytest \
7 "