summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-smpplib_2.1.0.bb24
-rw-r--r--meta-python/recipes-devtools/python/python3-smpplib_2.2.0.bb30
2 files changed, 30 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python3-smpplib_2.1.0.bb b/meta-python/recipes-devtools/python/python3-smpplib_2.1.0.bb
deleted file mode 100644
index 56d8f9eea..000000000
--- a/meta-python/recipes-devtools/python/python3-smpplib_2.1.0.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1SUMMARY = "SMPP library for python"
2SECTION = "devel/python"
3LICENSE = "GPLv3.0"
4LIC_FILES_CHKSUM = "file://README.md;md5=56a03d0ce7e492d4b9487b8aae957efe"
5
6PYPI_PACKAGE = "smpplib"
7SRC_URI[sha256sum] = "df4139a279b35fbb42a58f2a254a9c6daf362b04a7f94e208dc120e0b8a3fd4b"
8
9inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17 ${PYTHON_PN}-unittest \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23 sed -i 's/mock/unittest.mock/g' ${D}${PTEST_PATH}/tests/*
24}
diff --git a/meta-python/recipes-devtools/python/python3-smpplib_2.2.0.bb b/meta-python/recipes-devtools/python/python3-smpplib_2.2.0.bb
new file mode 100644
index 000000000..00a493914
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-smpplib_2.2.0.bb
@@ -0,0 +1,30 @@
1SUMMARY = "SMPP library for python"
2SECTION = "devel/python"
3LICENSE = "GPLv3.0"
4LIC_FILES_CHKSUM = "file://README.md;md5=8b4e2ac8cf248f7b991784f88b630852"
5
6PYPI_PACKAGE = "smpplib"
7SRC_URI[sha256sum] = "3d513178a35573f66faac4ef2127c4bd73307ddb463d145b17b013cf709d9ddd"
8
9inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN} += " \
16 ${PYTHON_PN}-logging \
17 ${PYTHON_PN}-six \
18"
19
20RDEPENDS:${PN}-ptest += " \
21 ${PYTHON_PN}-pytest \
22 ${PYTHON_PN}-unittest \
23 ${PYTHON_PN}-profile \
24 ${PYTHON_PN}-mock \
25"
26
27do_install_ptest() {
28 install -d ${D}${PTEST_PATH}/tests
29 cp -rf ${S}/smpplib/tests/* ${D}${PTEST_PATH}/tests/
30}