diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
3 files changed, 63 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aspectlib/0001-Remove-tornado-6-test-constraint.-Ref-15.patch b/meta-python/recipes-devtools/python/python3-aspectlib/0001-Remove-tornado-6-test-constraint.-Ref-15.patch new file mode 100644 index 000000000..174f088e9 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-aspectlib/0001-Remove-tornado-6-test-constraint.-Ref-15.patch | |||
@@ -0,0 +1,45 @@ | |||
1 | From d3ae6ac951cc5bbce29b9c987741e0a557c9b777 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Ionel=20Cristian=20M=C4=83rie=C8=99?= <contact@ionelmc.ro> | ||
3 | Date: Sun, 2 May 2021 09:50:43 +0300 | ||
4 | Subject: [PATCH] Remove tornado<6 test constraint. Ref #15. | ||
5 | |||
6 | Upstream-Status: Backport [https://github.com/ionelmc/python-aspectlib/commit/7dccb198dfb426f529b81a28a755f3c02f8b50cb] | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | tests/test_integrations_py3.py | 5 ++++- | ||
10 | tox.ini | 3 ++- | ||
11 | 2 files changed, 6 insertions(+), 2 deletions(-) | ||
12 | |||
13 | diff --git a/tests/test_integrations_py3.py b/tests/test_integrations_py3.py | ||
14 | index e025eac..596589d 100644 | ||
15 | --- a/tests/test_integrations_py3.py | ||
16 | +++ b/tests/test_integrations_py3.py | ||
17 | @@ -36,7 +36,10 @@ def test_decorate_tornado_coroutine(): | ||
18 | @gen.coroutine | ||
19 | @debug.log(print_to=buf, module=False, stacktrace=2, result_repr=repr) | ||
20 | def coro(): | ||
21 | - yield gen.Task(loop.add_timeout, timedelta(microseconds=10)) | ||
22 | + if hasattr(gen, 'Task'): | ||
23 | + yield gen.Task(loop.add_timeout, timedelta(microseconds=10)) | ||
24 | + else: | ||
25 | + yield gen.sleep(0.01) | ||
26 | return "result" | ||
27 | |||
28 | loop = ioloop.IOLoop.current() | ||
29 | diff --git a/tox.ini b/tox.ini | ||
30 | index 8c607de..08c31b3 100644 | ||
31 | --- a/tox.ini | ||
32 | +++ b/tox.ini | ||
33 | @@ -55,7 +55,8 @@ deps = | ||
34 | pytest-clarity | ||
35 | pytest-cov | ||
36 | pytest-travis-fold | ||
37 | - tornado<6.0 | ||
38 | + six | ||
39 | + tornado | ||
40 | commands = | ||
41 | {posargs:pytest --cov --cov-report=term-missing -vv --ignore=src} | ||
42 | |||
43 | -- | ||
44 | 2.32.0 | ||
45 | |||
diff --git a/meta-python/recipes-devtools/python/python3-aspectlib/run-ptest b/meta-python/recipes-devtools/python/python3-aspectlib/run-ptest new file mode 100644 index 000000000..b63c4de0d --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-aspectlib/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | ||
diff --git a/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb b/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb index 415a43067..2dc57a6bb 100644 --- a/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb +++ b/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb | |||
@@ -8,7 +8,21 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=d58b3f20fd10347a9458b8a03793b62e" | |||
8 | 8 | ||
9 | SRC_URI[sha256sum] = "d275ec82c4c2712e564bb760e4accff8f061f648e38774feabeb8b241cf3a4aa" | 9 | SRC_URI[sha256sum] = "d275ec82c4c2712e564bb760e4accff8f061f648e38774feabeb8b241cf3a4aa" |
10 | 10 | ||
11 | inherit pypi setuptools3 | 11 | inherit ptest pypi setuptools3 |
12 | |||
13 | SRC_URI += "file://run-ptest \ | ||
14 | file://0001-Remove-tornado-6-test-constraint.-Ref-15.patch \ | ||
15 | " | ||
16 | |||
17 | do_install_ptest() { | ||
18 | install -d ${D}${PTEST_PATH}/tests | ||
19 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
20 | } | ||
21 | |||
22 | RDEPENDS_${PN}-ptest += "\ | ||
23 | python3-tornado \ | ||
24 | python3-process-tests \ | ||
25 | " | ||
12 | 26 | ||
13 | RDEPENDS_${PN} += "python3-core python3-fields" | 27 | RDEPENDS_${PN} += "python3-core python3-fields" |
14 | 28 | ||