summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-xxhash_3.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-xxhash_3.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-xxhash_3.1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xxhash_3.1.0.bb b/meta-python/recipes-devtools/python/python3-xxhash_3.1.0.bb
new file mode 100644
index 000000000..bb7bdd314
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-xxhash_3.1.0.bb
@@ -0,0 +1,21 @@
1SUMMARY = "xxhash is a Python binding for the xxHash library by Yann Collet."
2SECTION = "devel/python"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3a9dab7f159514231249aa3e108ab26b"
5
6SRC_URI[sha256sum] = "ac21b1e21dc6fdfee9a57b53f4777539d53a84f2e1546a3f802f159f9966bdc1"
7
8SRC_URI += " \
9 file://run-ptest \
10"
11
12inherit pypi setuptools3 ptest
13
14RDEPENDS:${PN}-ptest += " \
15 ${PYTHON_PN}-pytest \
16"
17
18do_install_ptest() {
19 install -d ${D}${PTEST_PATH}/tests
20 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
21}