summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-wtforms_3.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-wtforms_3.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-wtforms_3.0.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-wtforms_3.0.1.bb b/meta-python/recipes-devtools/python/python3-wtforms_3.0.1.bb
new file mode 100644
index 000000000..36a0191dc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-wtforms_3.0.1.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "A flexible forms validation and rendering library for python web development."
2HOMEPAGE = "https://pypi.python.org/pypi/WTForms"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5
6LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=53dbfa56f61b90215a9f8f0d527c043d"
7
8SRC_URI[sha256sum] = "6b351bbb12dd58af57ffef05bc78425d08d1914e0fd68ee14143b7ade023c5bc"
9
10PYPI_PACKAGE = "WTForms"
11
12inherit pypi setuptools3
13
14DEPENDS += "\
15 ${PYTHON_PN}-pip-native \
16 ${PYTHON_PN}-babel-native \
17 "
18
19RDEPENDS:${PN} += "\
20 ${PYTHON_PN}-netserver \
21 ${PYTHON_PN}-numbers \
22 ${PYTHON_PN}-markupsafe \
23 "