diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-tox_4.25.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-tox_4.25.0.bb | 34 |
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-tox_4.25.0.bb b/meta-python/recipes-devtools/python/python3-tox_4.25.0.bb new file mode 100644 index 0000000000..c7a7d2e29c --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-tox_4.25.0.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | # SPDX-License-Identifier: MIT | ||
2 | # Copyright (C) 2023 iris-GmbH infrared & intelligent sensors | ||
3 | |||
4 | SUMMARY = "Automate and standardize testing in Python. It is part of a larger vision of easing the packaging, testing and release process of Python software (alongside pytest and devpi)." | ||
5 | HOMEPAGE = "https://tox.readthedocs.org/" | ||
6 | LICENSE = "MIT" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=11610a9d8fd95649cf8159be12b98cb7" | ||
8 | |||
9 | SRC_URI[sha256sum] = "dd67f030317b80722cf52b246ff42aafd3ed27ddf331c415612d084304cf5e52" | ||
10 | |||
11 | BBCLASSEXTEND = "native nativesdk" | ||
12 | inherit pypi python_hatchling | ||
13 | |||
14 | DEPENDS += "\ | ||
15 | python3-hatch-vcs-native \ | ||
16 | " | ||
17 | |||
18 | RDEPENDS:${PN} += "\ | ||
19 | python3-cachetools \ | ||
20 | python3-chardet \ | ||
21 | python3-colorama \ | ||
22 | python3-filelock \ | ||
23 | python3-packaging \ | ||
24 | python3-platformdirs \ | ||
25 | python3-pluggy \ | ||
26 | python3-pyproject-api \ | ||
27 | python3-tomli \ | ||
28 | python3-virtualenv \ | ||
29 | " | ||
30 | |||
31 | # Install all built-in python3 modules, as the software tested with tox might | ||
32 | # depend on it. Tox will attempt to install all required dependencies | ||
33 | # in a virtualenv using pip, but this obviously does not include the built-in modules. | ||
34 | RDEPENDS:${PN} += "python3-modules" | ||