summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-snagboot_1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-snagboot_1.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-snagboot_1.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-snagboot_1.2.bb b/meta-python/recipes-devtools/python/python3-snagboot_1.2.bb
new file mode 100644
index 000000000..57a3280de
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-snagboot_1.2.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Snagboot intends to be an open-source replacement vendor-specific tools used to recover and/or reflash embedded platforms."
2
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6SRC_URI[sha256sum] = "3d5cdd5ffe7355deba27657e6f45d45538a398f92215d219a8cfd6e716f67c34"
7
8inherit pypi python_setuptools_build_meta
9
10RDEPENDS:${PN} += " \
11 bash \
12 python3-fcntl \
13 python3-pyusb \
14 python3-pyyaml \
15 python3-setuptools \
16 python3-six \
17"
18
19do_install:append() {
20 install -D -m 0644 ${S}/src/snagrecover/50-snagboot.rules ${D}${sysconfdir}/udev/rules.d/50-snagboot.rules
21}