summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-redis_5.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-redis_5.1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-redis_5.1.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-redis_5.1.1.bb b/meta-python/recipes-devtools/python/python3-redis_5.1.1.bb
new file mode 100644
index 000000000..a7ccc9558
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-redis_5.1.1.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Python client for Redis key-value store"
2DESCRIPTION = "The Python interface to the Redis key-value store."
3HOMEPAGE = "http://github.com/andymccurdy/redis-py"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=609ded3add9111c4c6e102f1d421d3f8"
6
7# Prefix archive to avoid clashing with the main redis archives
8PYPI_ARCHIVE_NAME_PREFIX="pypi-"
9
10SRC_URI[sha256sum] = "f6c997521fedbae53387307c5d0bf784d9acc28d9f1d058abeac566ec4dbed72"
11
12inherit pypi setuptools3
13
14RDEPENDS:${PN} += " \
15 python3-asyncio \
16 python3-compression \
17 python3-cryptography \
18 python3-datetime \
19 python3-json \
20 python3-packaging \
21"