summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyproject-api_1.7.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyproject-api_1.7.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyproject-api_1.7.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyproject-api_1.7.2.bb b/meta-python/recipes-devtools/python/python3-pyproject-api_1.7.2.bb
new file mode 100644
index 000000000..ee8949add
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyproject-api_1.7.2.bb
@@ -0,0 +1,23 @@
1# SPDX-License-Identifier: MIT
2# Copyright (C) 2023 iris-GmbH infrared & intelligent sensors
3
4SUMMARY = "pyproject-api aims to abstract away interaction with pyproject.toml style projects in a flexible way."
5HOMEPAGE = "https://pyproject-api.readthedocs.io"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=11610a9d8fd95649cf8159be12b98cb7"
8
9SRC_URI[sha256sum] = "dc5b0e0f6e291a4f22b46e182c9c6d4915c62b1f089b8de1b73f2d06ae453593"
10
11PYPI_PACKAGE = "pyproject_api"
12
13BBCLASSEXTEND = "native nativesdk"
14inherit pypi python_hatchling
15
16DEPENDS += "\
17 python3-hatch-vcs-native \
18"
19
20RDEPENDS:${PN} += "\
21 python3-packaging \
22 python3-tomli \
23"