summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyproj_3.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyproj_3.5.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyproj_3.5.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyproj_3.5.0.bb b/meta-python/recipes-devtools/python/python3-pyproj_3.5.0.bb
new file mode 100644
index 000000000..f67090da7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyproj_3.5.0.bb
@@ -0,0 +1,17 @@
1SUMMARY = "Python interface to PROJ (cartographic projections and coordinate transformations library)"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=873757af01d2d221eedb422c4c1dd163"
4DEPENDS = "python3-cython proj"
5DEPENDS:append:class-target = " python3-cython-native proj-native"
6
7PYPI_PACKAGE = "pyproj"
8
9inherit pypi setuptools3
10
11SRC_URI[sha256sum] = "9859d1591c1863414d875ae0759e72c2cffc01ab989dc64137fbac572cc81bf6"
12
13RDEPENDS:${PN} = "${PYTHON_PN}-certifi proj"
14
15export PROJ_INCDIR = "${STAGING_INCDIR}"
16export PROJ_LIBDIR = "${STAGING_LIBDIR}"
17export PROJ_DIR = "${STAGING_BINDIR_NATIVE}/.."