summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyopenssl_22.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyopenssl_22.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyopenssl_22.0.0.bb23
1 files changed, 0 insertions, 23 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyopenssl_22.0.0.bb b/meta-python/recipes-devtools/python/python3-pyopenssl_22.0.0.bb
deleted file mode 100644
index db0e809ef..000000000
--- a/meta-python/recipes-devtools/python/python3-pyopenssl_22.0.0.bb
+++ /dev/null
@@ -1,23 +0,0 @@
1SUMMARY = "Simple Python wrapper around the OpenSSL library"
2HOMEPAGE = "https://pyopenssl.org/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6DEPENDS += "openssl ${PYTHON_PN}-cryptography"
7
8SRC_URI[sha256sum] = "660b1b1425aac4a1bea1d94168a85d99f0b3144c869dd4390d27629d0087f1bf"
9
10PYPI_PACKAGE = "pyOpenSSL"
11inherit pypi setuptools3
12
13PACKAGES =+ "${PN}-tests"
14FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
15
16RDEPENDS:${PN}:class-target = " \
17 ${PYTHON_PN}-cryptography \
18 ${PYTHON_PN}-six \
19 ${PYTHON_PN}-threading \
20"
21RDEPENDS:${PN}-tests = "${PN}"
22
23BBCLASSEXTEND = "native nativesdk"