summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pylint_3.3.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pylint_3.3.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pylint_3.3.4.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pylint_3.3.4.bb b/meta-python/recipes-devtools/python/python3-pylint_3.3.4.bb
new file mode 100644
index 0000000000..92378d7fda
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pylint_3.3.4.bb
@@ -0,0 +1,58 @@
1SUMMARY = "Pylint is a Python source code analyzer"
2HOMEPAGE = "http://www.pylint.org/"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
5
6SRCREV = "c2b01c3d0b6410d4c93eb1f32fb28f2116b1e68f"
7SRC_URI += "git://github.com/pylint-dev/pylint;branch=main;protocol=https \
8 file://0001-Adjust-test-expectations-for-ptest.patch \
9 file://run-ptest \
10 "
11
12inherit python_setuptools_build_meta ptest
13
14S = "${WORKDIR}/git"
15
16RDEPENDS:${PN} += "\
17 python3-astroid \
18 python3-difflib \
19 python3-dill \
20 python3-isort \
21 python3-json \
22 python3-mccabe \
23 python3-netserver \
24 python3-numbers \
25 python3-pkgutil \
26 python3-platformdirs \
27 python3-shell \
28 python3-tomlkit \
29 "
30# python3-misc for timeit.py
31RDEPENDS:${PN}-ptest += " \
32 python3-core \
33 python3-git \
34 python3-misc \
35 python3-py \
36 python3-pytest \
37 python3-pytest-benchmark \
38 python3-pytest-runner \
39 python3-pytest-timeout \
40 python3-pytest-xdist \
41 python3-requests \
42 python3-statistics \
43 python3-tomllib \
44 python3-typing-extensions \
45 python3-unittest-automake-output \
46 "
47
48do_install_ptest() {
49 install -d ${D}${PTEST_PATH}/tests
50 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
51 install -Dm 0644 ${S}/tests/.pylint_primer_tests/.gitkeep ${D}${PTEST_PATH}/tests/.pylint_primer_tests/.gitkeep
52 sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/a_script
53 # regression_distutil_import_error_73.py fails to run see
54 # https://lists.openembedded.org/g/openembedded-devel/topic/103181847
55 rm ${D}${PTEST_PATH}/tests/functional/r/regression_02/regression_distutil_import_error_73.py
56}
57
58BBCLASSEXTEND = "native nativesdk"