diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pydantic_2.9.2.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pydantic_2.9.2.bb | 64 |
1 files changed, 64 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pydantic_2.9.2.bb b/meta-python/recipes-devtools/python/python3-pydantic_2.9.2.bb new file mode 100644 index 000000000..b776d05dc --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pydantic_2.9.2.bb | |||
@@ -0,0 +1,64 @@ | |||
1 | SUMMARY = "Data validation using Python type hinting" | ||
2 | DESCRIPTION = "Data validation and settings management using Python \ | ||
3 | type hints.\ | ||
4 | \ | ||
5 | Fast and extensible, Pydantic plays nicely with your linters/IDE/brain. \ | ||
6 | Define how data should be in pure, canonical Python 3.7+; validate it with \ | ||
7 | Pydantic." | ||
8 | HOMEPAGE = "https://github.com/samuelcolvin/pydantic" | ||
9 | LICENSE = "MIT" | ||
10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=09280955509d1c4ca14bae02f21d49a6" | ||
11 | |||
12 | inherit pypi python_hatchling | ||
13 | |||
14 | SRC_URI[sha256sum] = "d155cef71265d1e9807ed1c32b4c8deec042a44a50a4188b25ac67ecd81a9c0f" | ||
15 | |||
16 | DEPENDS += "python3-hatch-fancy-pypi-readme-native" | ||
17 | |||
18 | RECIPE_NO_UPDATE_REASON = "Must be updated in sync with python3-pydantic-core." | ||
19 | |||
20 | RDEPENDS:${PN} += "\ | ||
21 | python3-annotated-types \ | ||
22 | python3-core \ | ||
23 | python3-datetime \ | ||
24 | python3-image \ | ||
25 | python3-io \ | ||
26 | python3-json \ | ||
27 | python3-jsonschema \ | ||
28 | python3-logging \ | ||
29 | python3-netclient \ | ||
30 | python3-numbers \ | ||
31 | python3-profile \ | ||
32 | python3-pydantic-core \ | ||
33 | python3-typing-extensions \ | ||
34 | python3-tzdata \ | ||
35 | python3-zoneinfo \ | ||
36 | " | ||
37 | |||
38 | inherit ptest | ||
39 | SRC_URI += "file://run-ptest" | ||
40 | RDEPENDS:${PN}-ptest += "\ | ||
41 | python3-cloudpickle \ | ||
42 | python3-dirty-equals \ | ||
43 | python3-email-validator \ | ||
44 | python3-html \ | ||
45 | python3-hypothesis \ | ||
46 | python3-pydoc \ | ||
47 | python3-pytest \ | ||
48 | python3-pytest-mock \ | ||
49 | python3-rich \ | ||
50 | python3-unittest-automake-output \ | ||
51 | python3-unixadmin \ | ||
52 | " | ||
53 | |||
54 | do_install_ptest() { | ||
55 | cp -rf ${S}/tests/ ${D}${PTEST_PATH}/ | ||
56 | # Requires 'ruff' (python3-ruff) which we cannot build | ||
57 | # until we have Rust 1.71+ in oe-core | ||
58 | rm -f ${D}${PTEST_PATH}/tests/test_docs.py | ||
59 | # We are not trying to support mypy | ||
60 | rm -f ${D}${PTEST_PATH}/tests/test_mypy.py | ||
61 | # We are not trying to run benchmarks | ||
62 | rm -rf ${D}${PTEST_PATH}/tests/benchmarks | ||
63 | sed -i -e "/--automake/ s/$/ -k 'not test_config_validation_error_cause and not test_dataclass_config_validate_default and not test_annotated_validator_nested and not test_use_bare and not test_use_no_fields and not test_validator_bad_fields_throws_configerror and not test_assert_raises_validation_error and not test_model_config_validate_default'/" ${D}${PTEST_PATH}/run-ptest | ||
64 | } | ||