diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-protobuf_3.19.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-protobuf_3.19.0.bb | 39 |
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-protobuf_3.19.0.bb b/meta-python/recipes-devtools/python/python3-protobuf_3.19.0.bb new file mode 100644 index 000000000..4ef51c6c2 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-protobuf_3.19.0.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | DESCRIPTION = "Protocol Buffers" | ||
2 | HOMEPAGE = "https://developers.google.com/protocol-buffers/" | ||
3 | SECTION = "devel/python" | ||
4 | |||
5 | LICENSE = "BSD-3-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=19e8f490f9526b1de84f8d949cfcfd4e" | ||
7 | |||
8 | inherit pypi setuptools3 | ||
9 | |||
10 | SRC_URI[sha256sum] = "6a1dc6584d24ef86f5b104bcad64fa0fe06ed36e5687f426e0445d363a041d18" | ||
11 | |||
12 | # http://errors.yoctoproject.org/Errors/Details/184715/ | ||
13 | # Can't find required file: ../src/google/protobuf/descriptor.proto | ||
14 | CLEANBROKEN = "1" | ||
15 | |||
16 | UPSTREAM_CHECK_REGEX = "protobuf/(?P<pver>\d+(\.\d+)+)/" | ||
17 | |||
18 | DEPENDS += "protobuf" | ||
19 | |||
20 | RDEPENDS:${PN} += " \ | ||
21 | ${PYTHON_PN}-datetime \ | ||
22 | ${PYTHON_PN}-json \ | ||
23 | ${PYTHON_PN}-logging \ | ||
24 | ${PYTHON_PN}-netclient \ | ||
25 | ${PYTHON_PN}-numbers \ | ||
26 | ${PYTHON_PN}-pkgutil \ | ||
27 | ${PYTHON_PN}-six \ | ||
28 | ${PYTHON_PN}-unittest \ | ||
29 | " | ||
30 | |||
31 | # For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools) | ||
32 | BBCLASSEXTEND = "native nativesdk" | ||
33 | |||
34 | DISTUTILS_BUILD_ARGS += "--cpp_implementation" | ||
35 | DISTUTILS_INSTALL_ARGS += "--cpp_implementation" | ||
36 | |||
37 | do_compile:prepend:class-native () { | ||
38 | export KOKORO_BUILD_NUMBER="1" | ||
39 | } | ||