diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pint_0.24.3.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pint_0.24.3.bb | 43 |
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pint_0.24.3.bb b/meta-python/recipes-devtools/python/python3-pint_0.24.3.bb new file mode 100644 index 000000000..337f58720 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pint_0.24.3.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | SUMMARY = "Physical quantities module" | ||
2 | DESCRIPTION = "Physical quantities Python module" | ||
3 | HOMEPAGE = "https://github.com/hgrecco/pint" | ||
4 | SECTION = "devel/python" | ||
5 | |||
6 | LICENSE = "BSD-3-Clause" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b" | ||
8 | |||
9 | inherit pypi ptest python_setuptools_build_meta | ||
10 | |||
11 | SRC_URI[sha256sum] = "d54771093e8b94c4e0a35ac638c2444ddf3ef685652bab7675ffecfa0c5c5cdf" | ||
12 | |||
13 | DEPENDS += "python3-setuptools-scm-native" | ||
14 | |||
15 | BBCLASSEXTEND = "native nativesdk" | ||
16 | |||
17 | SRC_URI += " \ | ||
18 | file://run-ptest \ | ||
19 | file://0001-dataclass-frozen-True-for-Python-3.13-compatibility.patch \ | ||
20 | " | ||
21 | |||
22 | RDEPENDS:${PN} += " \ | ||
23 | python3-setuptools \ | ||
24 | python3-packaging \ | ||
25 | " | ||
26 | # python3-misc for timeit.py | ||
27 | RDEPENDS:${PN}-ptest += " \ | ||
28 | python3-appdirs \ | ||
29 | python3-attrs \ | ||
30 | python3-flexcache \ | ||
31 | python3-flexparser \ | ||
32 | python3-misc \ | ||
33 | python3-pytest \ | ||
34 | python3-pytest-benchmark \ | ||
35 | python3-pytest-subtests \ | ||
36 | python3-statistics \ | ||
37 | python3-unittest-automake-output \ | ||
38 | " | ||
39 | |||
40 | do_install_ptest() { | ||
41 | install -d ${D}${PTEST_PATH}/testsuite | ||
42 | cp -rf ${S}/pint/* ${D}${PTEST_PATH}/ | ||
43 | } | ||