summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-paho-mqtt_2.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-paho-mqtt_2.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-paho-mqtt_2.0.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-paho-mqtt_2.0.0.bb b/meta-python/recipes-devtools/python/python3-paho-mqtt_2.0.0.bb
new file mode 100644
index 000000000..e4cf77a13
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-paho-mqtt_2.0.0.bb
@@ -0,0 +1,37 @@
1SUMMARY = "MQTT version 3.1/3.1.1 client library"
2LICENSE = "EPL-1.0 | EDL-1.0"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8e5f264c6988aec56808a3a11e77b913 \
4 file://edl-v10;md5=c09f121939f063aeb5235972be8c722c \
5"
6SRCNAME = "paho-mqtt"
7
8inherit pypi python_hatchling python_setuptools_build_meta
9
10SRC_URI[sha256sum] = "13b205f29251e4f2c66a6c923c31fc4fd780561e03b2d775cff8e4f2915cf947"
11
12PYPI_SRC_URI = "https://files.pythonhosted.org/packages/73/b7/a4df0f93bbdae237e16ba402752151eceee576cbe80c235a2475fbf81eea/paho_mqtt-${PV}.tar.gz"
13
14S = "${WORKDIR}/paho_mqtt-${PV}"
15
16DEPENDS += "python3-pytest-runner-native"
17
18do_install:append() {
19 install -d -m0755 ${D}${datadir}/${BPN}/examples
20 cp --preserve=mode,timestamps -R ${S}/examples/* ${D}${datadir}/${BPN}/examples
21}
22
23PACKAGES =+ "${PN}-examples"
24
25RDEPENDS:${PN}-examples += "${PN} python3-core"
26
27FILES:${PN}-examples = "${datadir}/${BPN}/examples"
28
29RDEPENDS:${PN} = "\
30 python3-io \
31 python3-logging \
32 python3-math \
33 python3-netclient \
34 python3-threading \
35"
36
37BBCLASSEXTEND = "native nativesdk"