summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-netaddr_1.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-netaddr_1.3.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-netaddr_1.3.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-netaddr_1.3.0.bb b/meta-python/recipes-devtools/python/python3-netaddr_1.3.0.bb
new file mode 100644
index 000000000..b8a772566
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-netaddr_1.3.0.bb
@@ -0,0 +1,25 @@
1SUMMARY = "A network address manipulation library for Python."
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=8afa43eca873b71d5d85dd0be1f707fa"
4
5SRC_URI[sha256sum] = "5c3c3d9895b551b763779ba7db7a03487dc1f8e3b385af819af341ae9ef6e48a"
6
7inherit pypi python_setuptools_build_meta ptest
8
9SRC_URI += " \
10 file://run-ptest \
11"
12
13RDEPENDS:${PN}-ptest += " \
14 python3-pytest \
15 python3-unittest-automake-output \
16"
17
18do_install_ptest() {
19 install -d ${D}${PTEST_PATH}/tests
20 cp -rf ${S}/netaddr/tests/* ${D}${PTEST_PATH}/tests/
21}
22
23do_install_ptest:append:libc-musl () {
24 sed -i -e "/--automake/ s/$/ -k 'not test_strategy_ipv6'/" ${D}${PTEST_PATH}/run-ptest
25}