summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-multidict_6.0.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-multidict_6.0.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-multidict_6.0.5.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-multidict_6.0.5.bb b/meta-python/recipes-devtools/python/python3-multidict_6.0.5.bb
new file mode 100644
index 000000000..b12e180d0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-multidict_6.0.5.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Multidicts are useful for working with HTTP headers, URL query args etc."
2HOMEPAGE = "https://github.com/aio-libs/multidict/"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b4fef6e4b0828c2401fb983363985b39"
6
7inherit pypi setuptools3 ptest
8
9PV .= "+git"
10
11SRCREV = "a9b281b2ef4ab25d95d6b268aa88c428e75c3696"
12PYPI_SRC_URI = "git://github.com/aio-libs/multidict;branch=master;protocol=https"
13S = "${WORKDIR}/git"
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
19RDEPENDS:${PN}-ptest += " \
20 python3-pytest \
21 python3-pytest-cov \
22 python3-unittest-automake-output \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/tests
27 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
28}
29
30BBCLASSEXTEND = "native nativesdk"