summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-multidict_5.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-multidict_5.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-multidict_5.1.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-multidict_5.1.0.bb b/meta-python/recipes-devtools/python/python3-multidict_5.1.0.bb
new file mode 100644
index 000000000..b960affac
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-multidict_5.1.0.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Multidicts are useful for working with HTTP headers, URL query args etc."
2HOMEPAGE = "https://github.com/aio-libs/multidict/"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e74c98abe0de8f798ca609137f9cef4a"
6
7SRC_URI[sha256sum] = "25b4e5f22d3a37ddf3effc0710ba692cfc792c2b9edfb9c05aefe823256e84d5"
8
9inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS_${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23
24BBCLASSEXTEND = "native nativesdk"