summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-langtable_0.0.52.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-langtable_0.0.52.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-langtable_0.0.52.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-langtable_0.0.52.bb b/meta-python/recipes-devtools/python/python3-langtable_0.0.52.bb
new file mode 100644
index 000000000..e6ccd7b54
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-langtable_0.0.52.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "langtable is used to guess reasonable defaults for locale,\
2keyboard, territory"
3HOMEPAGE = "https://github.com/mike-fabian/langtable/"
4LICENSE = "GPLv3+"
5SECTION = "devel/python"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
9SRC_URI[md5sum] = "240a62b84ed29f6530ceae60609f7eff"
10SRC_URI[sha256sum] = "a2c499704c91c0a23e5db92e80ad1d45e51466b82ffaee478e5bb781460b3db5"
11
12inherit pypi setuptools3 python3native
13
14DISTUTILS_INSTALL_ARGS += " \
15 --install-data=${datadir}/langtable"
16
17FILES_${PN} += "${datadir}/*"
18
19RDEPENDS_${PN} += " \
20 ${PYTHON_PN}-compression \
21 ${PYTHON_PN}-doctest \
22 ${PYTHON_PN}-logging \
23 ${PYTHON_PN}-xml \
24"