summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-httpcore_1.0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-httpcore_1.0.6.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-httpcore_1.0.6.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-httpcore_1.0.6.bb b/meta-python/recipes-devtools/python/python3-httpcore_1.0.6.bb
new file mode 100644
index 000000000..43c5629a2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-httpcore_1.0.6.bb
@@ -0,0 +1,26 @@
1SUMMARY = "A minimal low-level HTTP client."
2SECTION = "devel/python"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.md;md5=1c1f23b073da202e1f4f9e426490210c"
5
6inherit pypi python_hatchling
7
8SRC_URI[sha256sum] = "73f6dbd6eb8c21bbf7ef8efad555481853f5f6acdeaff1edb0694289269ee17f"
9
10DEPENDS += "\
11 python3-hatch-fancy-pypi-readme-native \
12"
13
14PACKAGECONFIG ??= ""
15PACKAGECONFIG[http2] = ",,,python3-h2"
16PACKAGECONFIG[socks] = ",,,python3-socksio"
17PACKAGECONFIG[asyncio] = ",,,python3-anyio"
18# Don't provide "trio" PACKAGECONFIG as nothing provides "python3-trio" currently.
19# If somebody needs this please feel free to add python3-trio and enable the
20# packageconfig below:
21#PACKAGECONFIG[trio] = ",,,python3-trio"
22
23RDEPENDS:${PN} += "\
24 python3-certifi \
25 python3-h11 \
26"