summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-h5py_3.10.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-h5py_3.10.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-h5py_3.10.0.bb40
1 files changed, 0 insertions, 40 deletions
diff --git a/meta-python/recipes-devtools/python/python3-h5py_3.10.0.bb b/meta-python/recipes-devtools/python/python3-h5py_3.10.0.bb
deleted file mode 100644
index 8a9158525..000000000
--- a/meta-python/recipes-devtools/python/python3-h5py_3.10.0.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python."
2HOMEPAGE = "https://www.h5py.org/"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c"
6
7SRC_URI[sha256sum] = "d93adc48ceeb33347eb24a634fb787efc7ae4644e6ea4ba733d099605045c049"
8
9SRC_URI += "file://0001-setup_build.py-avoid-absolute-path.patch \
10 file://0001-Fix-Cython-3-compatibility.patch"
11
12inherit pkgconfig pypi setuptools3
13
14BBCLASSEXTEND = "native"
15
16DEPENDS = "python3-pkgconfig-native \
17 python3-cython-native \
18 python3-numpy-native \
19 python3-six-native \
20 hdf5-native \
21 python3 \
22 hdf5 \
23 "
24
25PACKAGESPLITFUNCS =+ "fix_cythonized_sources"
26
27fix_cythonized_sources() {
28 for f in `grep -l -r -e '\/* Generated by Cython.*/$' ${PKGD}${TARGET_DBGSRC_DIR}`; do
29 if [ -e $f ]; then
30 sed -i -e 's#${RECIPE_SYSROOT_NATIVE}##g' $f
31 fi
32 done
33}
34
35RDEPENDS:${PN} = "python3-numpy \
36 python3-six \
37 python3-json \
38 "
39
40export HDF5_VERSION="1.14.0"