summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-grpcio_1.37.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio_1.37.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio_1.37.0.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio_1.37.0.bb b/meta-python/recipes-devtools/python/python3-grpcio_1.37.0.bb
new file mode 100644
index 000000000..47fb71120
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-grpcio_1.37.0.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "Google gRPC"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7DEPENDS += "${PYTHON_PN}-protobuf"
8
9SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
10SRC_URI_append_class-target = " file://ppc-boringssl-support.patch \
11 file://riscv64_support.patch \
12 file://boring_ssl.patch \
13 file://mips_bigendian.patch \
14 file://0001-absl-always-use-asm-sgidefs.h.patch \
15"
16SRC_URI[sha256sum] = "b3ce16aa91569760fdabd77ca901b2288152eb16941d28edd9a3a75a0c4a8a85"
17
18RDEPENDS_${PN} = "${PYTHON_PN}-protobuf \
19 ${PYTHON_PN}-setuptools \
20 ${PYTHON_PN}-six \
21"
22
23inherit setuptools3
24inherit pypi
25
26export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY = "1"
27
28BORING_SSL_PLATFORM_arm = "linux-arm"
29BORING_SSL_PLATFORM_x86-64 = "linux-x86_64"
30BORING_SSL_PLATFORM ?= "unsupported"
31export GRPC_BORING_SSL_PLATFORM = "${BORING_SSL_PLATFORM}"
32
33BORING_SSL_x86-64 = "1"
34BORING_SSL_arm = "1"
35BORING_SSL ?= "0"
36export GRPC_BUILD_WITH_BORING_SSL_ASM = "${BORING_SSL}"
37
38GRPC_CFLAGS_append_toolchain-clang = " -fvisibility=hidden -fno-wrapv -fno-exceptions"
39export GRPC_PYTHON_CFLAGS = "${GRPC_CFLAGS}"
40
41CLEANBROKEN = "1"
42
43BBCLASSEXTEND = "native nativesdk"
44
45CCACHE_DISABLE = "1"
46
47# needs vdso support
48COMPATIBLE_HOST_libc-musl_powerpc64le = "null"
49