summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-grpcio-tools_1.66.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio-tools_1.66.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio-tools_1.66.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio-tools_1.66.2.bb b/meta-python/recipes-devtools/python/python3-grpcio-tools_1.66.2.bb
new file mode 100644
index 000000000..6765bed04
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-grpcio-tools_1.66.2.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "Google gRPC tools"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
7
8inherit pypi setuptools3
9
10PYPI_PACKAGE = "grpcio_tools"
11
12DEPENDS += "python3-grpcio"
13
14SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch \
15 file://0001-protobuf-Disable-musttail-attribute-on-mips.patch \
16 "
17SRC_URI[sha256sum] = "4a36e07913d26ba5ccfd2685ba63ca97f26b08c249d2cc9e74dda37efa49d7e4"
18
19RDEPENDS:${PN} = "python3-grpcio"
20
21BBCLASSEXTEND = "native nativesdk"