summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-google-auth_2.19.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-google-auth_2.19.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-google-auth_2.19.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-google-auth_2.19.0.bb b/meta-python/recipes-devtools/python/python3-google-auth_2.19.0.bb
new file mode 100644
index 000000000..52d93abac
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-auth_2.19.0.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Google Authentication Library"
2HOMEPAGE = "https://github.com/googleapis/google-auth-library-python"
3AUTHOR = "Google Cloud Platform"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6
7inherit pypi setuptools3
8
9SRC_URI[sha256sum] = "f39d528077ac540793dd3c22a8706178f157642a67d874db25c640b7fead277e"
10
11RDEPENDS:${PN} += "\
12 ${PYTHON_PN}-asyncio \
13 ${PYTHON_PN}-datetime \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-json \
16 ${PYTHON_PN}-logging \
17 ${PYTHON_PN}-netclient \
18 ${PYTHON_PN}-numbers \
19"
20
21RDEPENDS:${PN} += "\
22 ${PYTHON_PN}-aiohttp \
23 ${PYTHON_PN}-cachetools \
24 ${PYTHON_PN}-pyasn1-modules \
25 ${PYTHON_PN}-rsa \
26 ${PYTHON_PN}-six \
27"